[How-To] Create addon heels OR hide hair with addon hat

Hello, if it is your first time with my YMTEditor, or with addon clothes, please read my other tutorial first.

Other tutorial - read this if you didn’t before!

YMTEditor https://github.com/grzybeek/YMTEditor/releases


Important: This tutorial regarding hats/hair will only work with hair that has special bone( MH_Hair_Scale) applied and rigged properly. All GTA hairstyles have that bone, 98% of custom made hair doesn’t, and it won’t work



In this tutorial I will use these heels and hat from GTA.


Step 1

Create new YMT and change properties


After creating your YMT, adding your drawable and textures, you have to change component/prop properties.

HEELS:

If you want your heels to have “walking sound”, you have to change hash_2FD08CEF in component properties from none to shoe_heels

HAT:

Those values are what GTA uses mostly, if you want to hide hair completely, use -1.0 for example.

Step 2

Save and generate CreatureMetadata file


First save YMT, and then click “Generate CreatureMetadata”
3

Step 3

Prepare files and resource

You have to put file name of generated creaturemetadata between “creatureMetaData” fields in your .meta file!
Creaturemetadata file has to be inside ‘stream’ folder.

Important: All clothing props require little different streaming name, as you can see on screenshot above. Simply add “p” between pedName and dlcName and remember that naming is slightly different than in components!

For example:

  • ydd: “mp_f_freemode_01_p_addontutorial2^p_head_000”
  • ytd: “mp_f_freemode_01_p_addontutorial2^p_head_diff_000_a”

Results




End

If you have any questions, feel free to ask!

21 Likes

I have been waiting for a way to do this easily for such a long time. Thank you so much!

1 Like

nicee

2 Likes

does this work with peds as well?

1 Like

Thank you very much for the job you do for the comunity! We love you!

2 Likes

@Kayla_Corbo @khoerulageng @AlvarGG Thanks!

@T1GerQ8 Not sure about that, didn’t test it by myself but there is CreatureMetadata field in peds.meta, so I guess it should work, please test it and let me know!

1 Like

Thanks mate, love your work.
I assume once we start approaching 7 ymts (including the new creaturemetadata) its best to repack all your clothing addons into a single ymt to avoid crashing?

1 Like

Yeah, exactly. It depends which game version your server is running.
1604 = 14 .ymt’s limit
2189 = 6 .ymt’s limit
2372 = 4 ymt’s limit
Also, be aware that there is also limit inside each ymt, you can only have 0-127 drawables for each component.

2 Likes

Hay there so I have followed both of your tutorials and am not able to get hair (Default GTA hair) to be removed/squashed down for my addon hats just wondering if there is something I am missing @grzybeek

1 Like

That means either you didn’t do it properly or issue i’ve discovered yesterday is messing your files.
Simply you just need expressionMods value, and creaturemetadata file - if you have both of these then it should work.

Yesterday @TRZL reported me a bug with YMTEditor which completely removes all props with loading existing .ymt and saving, currently only making new one works :frowning: I’ll try to fix that as fast as possible.

1 Like

Thanks for getting back to me, all other steps ive followed have worked Ive converted everything to be addon. Shoes arent working for me though but im going to be looking into that myself luckily this is only on my localhost and I dont have a lot of EUP to go through so I might just see if making a new .ymt file for it works and fixes the shoe issue as for the hair ill wait and see

Edit:
Used another skin menu now the shoes are working perfectly just the hair not being shrunk is the only issue now

1 Like

I noticed an unnecessary Item entry with was being generated on export of creaturemetadata when generating that also has a entry. Probably has no effect on FiveM much, but could be of influence.

2 Likes

Yeah, there is one <Item> entry generated with -1 index, without that I’ve been getting random crashes, i’ve checked few R* creaturemetadata files, and most of them also had that entry with -1 index

1 Like

Sorry, it looks like the HTML destroyed my entry xD I meant to write:

I noticed an unnecessary pedCompExpressions Item entry with pedPropVarIndex value="-1"/ was being generated on export of creaturemetadata when generating pedPropExpressions that also has a pedPropVarIndex value="-1"/ entry. Probably has no effect on FiveM much, but could be of influence.

Basically, having two -1 entries makes the game crash as well as having none. Easily edited in RPF Explorer, but still something to keep in mind.

1 Like

Yeah, that’s why it generates those -1 entries, it’s not unnecessary, idk how did you get two -1 entries, I’ve been testing and always got only one (one in pedprop’s and one in pedcomp’s)

1 Like

Idk why, but having two -1 entries crashed my game. Removing the second entry made everything stable again. Anyways, thank you for the editor/creator! I hope to release my first clothing DLC soonish.

1 Like

Weird… I didn’t have any crashes with both -1 entries… Can you maybe send me your resource which was crashing? I guess it’s time to report it so it won’t crash anyone even without those -1 entries

1 Like

Sorry for the previous confusion. I’ve completely redone all my entries from scratch on a fresh YMT and with auto generated data it all works fine now. No idea what went wrong, but even with the extra -1 entry (which I didn’t confront in vanilla data before), things work as intended. :smiley:

1 Like

Seems my creaturemetadata file keeps causing crashes. When I take it out, I have no issues. I’m trying to get heels to work, which worked fine on it’s own, but once I added the rest of the items (including all the clothes and props) even though I didnt edit any espressions values aside from the shoes, it crashes.
I see two -1 values when I open it up in RPF explorer as well.

1 Like

How many .ymt’s do you have? And which game version your server is running? Maybe you are hitting this limit?
Creaturemetadata file is very unknown (at least for me), those two -1 entries are the ones that weren’t crashing me, so I left it like that, maybe there is another issue with that file :frowning:

1 Like