[How-To] Create addon heels OR hide hair with addon hat

I went in and removed the -1 entry and everything works. I’m not sure why it happened. The only thing that’s a bit off now is the shoes don’t make sounds when walking unless you move onto a different texture of flooring, which is odd, but doable.

For context, I started a new YMT, added all my items, and then changed component properties for the high heels as well as for a scarf that streams as a mask, I wanted it to partially hide vanilla hair.
I tried loading in and kept crashing when I tried to swap to a female ped.
I removed the edit to the mask component properties thinking that might have done it, but I still crashed.
I removed the creaturemetadata completely and that worked.
I checked it in the RPF explorer, removed the second -1 entry, and it works fine now.
Throughout this I saved and reloaded the YMT multiple times.

I’m going to be converting over my entire server using this tool, so I’ll let you know if I have any other issues.

Which second entry? There should be only 2 entries with -1 (one pedProp and one pedComp) which one did you remove?

And I’m glad everything works now!

I am trying to edit a ymt created by gtautil, however every time I try to open the “Component Properties” there is nothing there. It just says “don’t touch it if you don’t know what you are doing” but I see no options. It’s just blank. Am I missing something or are “gtautil” ymts locked or something? Is there any way I can have the options to show up? I really want to fix these high heels :frowning:

Hey! Seems like gtautil isn’t generating it, you can re-generate it with my editor by just opening, saving and opening again

Hey. I tried doing this and after the file saved I got a “Failed to save YMT. please report it”. I tried to message you on discord but I am not sure how to do that with someone who isn’t my friend. The file still saved I think cause I see it. However it went from 33kb to 3,890kb. And when I open this new file it still doesn’t show the component properties. Not sure what could be causing this.

Well, yea, it failed to save, so it won’t change anything in that file. Can you please send me somewhere your YMT that you are trying to save?

Oof, sorry, missed this. I removed the -1 entry for pedProp and it works fine after that.

I did run into a new issue I haven’t experienced before. I’ve added new clothing to the same ymt once or twice since my last post and they worked perfectly, but upon adding some new items today, I crashed.

I tried troubleshooting, generated a new creaturemetadata (just in case) and edited it again, even removed it completely, but I still crash, so it seems to be an issue with the ymt itself. Not sure why, it was a couple accs, a couple jbibs, and a lowr. I’m not near the drawable limit for each component either, and I haven’t put in any new ymts, just replaced old ones.

Any ideas or anyone else having similar issues?

Edit: I just looked at the models, and noticed the poly count on some of them are SUPER high, but that hasn’t been an issue previously.

You’ve probably hit already known bug, or another new one which is not known, best would be creating bug report thread with a crash dump if you can’t find what’s your issue.

The bug which is known already - either me or fivem can’t fix it, since it’s related with codewalker (My editor uses codewalker code to save into .ymt), it just randomly corrupts few fields.

It was already reported to dexyfex(codewalker developer), but he doesn’t do any updates for now… Maybe some day it can be fixed

1 Like

Just an update:

Pretty sure it was those specific items that were the issue, the jbibs worked fine, but the lowr and accs were the issue. I used the existing YMT and have added multiple other lowr and accs drawables (condensed two packs into one as well as added new ones) and haven’t has any issues.

Also, just want to say thanks for making this editor, adding new items is so much easier and I know items are being added properly.

1 Like

[PT-BR]
Olá @grzybeek preciso de ajuda, estou fazendo algo incorreto ? testei sapatos altos para realmente ver de perto se funciona e não tenho sucesso com saltos alguem poderia me dizer oque estou fazendo de errado ?

já repeti 2 vezes o processo com diferentes sapatos altos e configs diferentes !
[IN-US]
Hi @grzybeek need help, am I doing something wrong? i tried high shoes to really see if it works up close and i have no success with heels could someone tell me what i’m doing wrong?

I’ve already repeated the process twice with different high shoes and different configs!



Screenshot_3
Screenshot_4

get it to work but I still have this bug with the above settings!

Hey, yes, you missed step 2 - generate creaturemetadata file, it should be placed in “stream” folder :slight_smile:

It works perfectly!
Thanks for the help @grzybeek I really didn’t care that I would need “createmetadata”

hello @grzybeek I’m testing all components and props and I can’t make the hat show up in the game, I’ll show in the prints the settings I used, I tried using -0.5 or - -1.0 for both male and female I’m using Creaturemetadata as you informed me, the slot appears nothing else is there, so far pants, jacket, masks, accessories worked perfectly, I will convert about 5800 clothes and I really need a little help!

here is the complete fileChapeu.rar (75.8 KB)

@DeadpoolBryan
Props .ydd should be named with one more “_p” between freemode_01 and your name, so for you it should be named: mp_m_freemode_01_p_addon^p_head_000.ydd, same for textures.

And you can use your original .ymt with all your clothes to add props, you shouldn’t create new .ymt only for props.

ok thanks, it worked perfectly


vests/task is not working I am using it as follows
I managed to make everything work, except the “task” vest,
today I’m going to start converting all my replace clothes into addon

Well, hard to tell what might be your issue, I’ve done tasks earlier and it did work for me. Everything looks fine on your video I think…

Edit: eCharacter in .meta should be “SCR_CHAR_MULTIPLAYER” for males, not sure if that’s the issue tho :stuck_out_tongue:

The problem is that my clothing store didn’t have all the vests so I fitted an invisible vest and had others ahead of me and I didn’t pay much attention.

everything works perfectly thanks for all the help @grzybeek