[RELEASE] [FREE] [STANDALONE] 3d- me, do, med

Hello guys.

Today I want to share with you the work that I’ve done.
image
image
image
All you have to do is plug & play (upload and use)

I took inspiration from SoDope
and the open source code from Noms to create my own 3dme / do / med.

I hope it can be an alternative version of scripts people want you to pay money for :slight_smile:

Download here

remember to leave a Like if u like it or use it, also leave a star on Github and follow me IF YOU WANT, I’d be happy. :hugs:

CARE: Its not adapted for Onesync Infinity YET! Will change soon!
UPDATE [12 January 2022]: Works now on Infinity.

26 Likes

looking good, thank you

1 Like

I started the resource and I have a problem at the time of putting myself to use the commands they come out to all the users I do not know if I understand

1 Like

Well, I guess u are using onesync infinity right?

Yes sir i am using that

Okay, I updated a fix, haven’t tested it yet tho.

So the idea behind that is that u have to check the player’s ID, its not really easy to figure out where to check it.

This is how it should look. I already added it into my github, you can just go ahead and download it again, not sure if that will fix it in the place where I added it. If it doesn’t you can try doing it yourself, but its definitely the way to fix this issue.

local myId = PlayerId()
local pid = GetPlayerFromServerId(id)

         if pid ~= -1 then
             if pid == myId then
                  --CODE HERE
             end
         end

Let me know if that fixed it.

4 Likes

change the lua client and at the moment of putting the commands they do not appear on the user, it does not mark an error or anything!

okay, I will work on it and try to find a result soon.

1 Like

This is very nice, thank you!

1 Like

doing the best I can!

1 Like

Hey, looks dope and we’re for sure going to be testing it soon!

One question though, is there a chance the commands could display both in 3D and in chat?

1 Like

Yes, I will be working on that in the future so watch out for updates!

1 Like

Would you know why all my commands work and come out in the bubble, except /me , its still same as old /me command , plain txt and no bubble ?

get rid of your old /me, sounds like its conflicting

yes, thats right. @RebellionRoleplay1 you can’t register 1 command twice. So get rid of the old one

1 Like

After taking out the script should i be removing anything else , as its still plain txt

you like it very much, very nice, but can you please make “infinity” compatible? looks like everyone and please dc log system

Discord Log Come please :slight_smile:

1 Like

Yes, I will be providing infinity support soon.

1 Like

Well, I think its really individual in your case. Maybe check something like esx_rpchat or any other script. Im pretty sure you have to have another RegisterCommand(‘me’) somewhere inside your scripts that you maybe don’t know about.