[CFX Keymaster] Will not resolve entire VPS IP range

Hello,

I am the SysAdmin for a server hosting company that draws a fair amount of FiveM communitites as clients. We offer general VPS hosting currently and have started having issues reported to us from our clients that the CFX Keymaster is not resolving their static VPS IPs. I have reproduced the issue myself with my own CFX.re Keymaster login and confirmed on both IP ranges we currently have allocated to us that no used or unused IP will resolve.

From what I have been told by others and through looking through on the forums, Keymaster uses Whois data in order to resolve and validate the IP. From a Whois query of a working IP address (my personal home IP) and one from our IP ranges (104.129.29.137) I cannot see the issue that might be causing this. This is quite inconvenient for our company and need to get this resolved as soon as possible.

The first image is our test VPS IP 104.129.29.137


Thank you for your time and assistance :slight_smile:

2 Likes

I am too having this problem with my VPS its really unlucky

Still no response on this, I really need to solve this ASAP…

Through a little bit of guess work and some helpful moderators, I have located what is most likely the issue. Assuming that Keymaster uses this WhoisResolver, there is a function that does not take in account the rwhois:// schema that may or may not be common for Datacenters to use in their whois data reporting. Our host Quadranet uses their own self hosted whois server to report customer info with whois info to properly identify the host of an IP address.

The current code of the WhoisResolver will return an invalid URL to the whois server if using the rwhois:// schema as seen the the response below because it keeps the “r” from before “whois://” in the schema and adds it to the url hostname.

    [exception:protected] => Unable to connect to rrwhois.quadranet.com:4321:4321 or missing configuration for this template.
    [parsedContacts:protected] => 
    [template] => Array
        (
            [rrwhois.quadranet.com:4321] => rrwhois.quadranet.com:4321
        )

This commit “should” fix the issue with the resolver and in turn CFX Keymaster once merged upstream.

It appears there must he some other additonal logic bug within the keymaster code that we do not have access to. Will update with any new thqt ai get as to a solution…

With help from our datacenter, we were able to implement a redirect from rrwhois.quadranet.com to their IP for the whois referral server. Unfortunately, as we discovered a couple of hours ago with the merge of the repaired Parser code into Keymaster. There seems to be additional buggy logic leading to the “could not resolve IP” error. I did attempt the registration again just to make sure and the same error came up. Since the Parser is ruled out as the culprit it is up to the CFX devs to implement a solution.

I would guess it might be some logic with not handling a referral server properly when those cases arise. Although rarer, they do come up in the datacenter hosting space from time to time.

Any updates on this problem yet? It’s driving me insane.

I have not heard anything about the status of a resolution. I have had a CFX community moderator confirm that the problem has been entered into an internal issue tracker to be investigated further. I have continued to request an update from @deterministic_bubble in Discord but have not heard back from them. They are a busy person though so I understand if they are preoccupied…

I am not sure if there are other issues that have taken precedence over looking into this issue. It would be good to get an update even if it was just to say they still have yet to attempt debugging it further than the Whois Parser logic.

I will update here once I hear more about this issue :slight_smile:

2 Likes

Quick Update!

Got in touch with a different element that is looking into the issue, will update when I know more. Hang in there guys!

If you are looking for quick workarounds, you can use a different IP when creating your keymaster key. This IP must be a valid public IP that you have access to running a quick fivem server on. In example your home internet IP or a friend’s internet IP. Once you make the key you must run a server, even a blank one once to “activate” and “validate” the key. After that you are free to use the key anywhere basically.

1 Like

Update time! :slight_smile:

Working with the elements more closely we discovered the fix was still not producing parsed results as other IP address Whois records. We found the the parsed object was mainly empty and contacts would not parse correctly. This was due to the WhoisParser not having accurate templates for referral servers. I am not sure how many variations of referral servers there are out there but for my IP block this should resolve. I have included a PR fix to add a template for Ubersmith RWhois Servers and also a check to take a look at the raw response for the Ubersmith header before throwing an exception and utilizing the last used template. Hopefully this resolves issues for others experiencing this issue.

If you continue to have issues after I update this thread that the issue has been resolved I urge you to please post your affected IP addresses here. I will take a look and see if there is some issue at the Parser level and try to relay a fix to CFX :slight_smile:

It is sad that people pay 50 dollars to register the IPs of their VPS and do not give priority to solve the case. in my case the IP error when registering has not been solved

The fix has not been pushed in yet. I will post when it does. Would you mind sharing your IP so I can see if you are having the same issue as the one we have created the fix for?

1 Like

What? There’s no such thing as ‘registering IPs’ and even if there were why would we charge for it?

in another account I have access to FiveM Element Club Platinum that I purchased, but I cannot register the IP of the servers because it cannot find the IP. I share the IP of one of our servers: 23.238.34.10, in case they can solve it

is fivem keymaster still a thing or is it just cfx keymaster

I believe they are both the same thing? I never had to change anything

I checked the response of your IP whois and it seems to be using the same or similar server to my host. I have modified my Pull Request to the WhoisParser code in order to resolve the resolution error for your IP as well.

Just waiting on the elements to push the code in. Again the more IPs I have to test, the more resolution errors I can fix. :slight_smile: Thanks for contributing your’s!

FiveM Keymaster was updated to CFX Keymaster when the CFX branding changes came into effect with the release of RedM more publicly. CFX is just the parent project of FiveM and RedM. They run the same code in most places.

This is the pull request we are waiting on to get pulled in upstream in order to update Keymaster and hopefully resolve the IP resolution errors in Keymaster once and for all :slight_smile:

As I have said before post your affected IPs to this forum thread and I will check them against the updated parser to make sure this fix will cover your IP

Hey fireant i cant not register server keys anymore either, anyway you could check the ip 174.3.134.174