Using the Steam API key manually on the server

I’m very sorry to hear that you are dissapointed by our Support. Do you already have a ticket about this? The Steam API will be automatically set for all our gameservers.

I really don’t understand what you mean by “put anything you want” like is there not anything I actually need to type in? Like do I put in my steam useraccount in the domain name bit or what?

do you have to do this for every player?


as for this question

No, you do not use your steam id it clearly says “domain” so it just needs to be a link just use thats what i did.

where is that

Good tutorial, hoping it’ll fix my issue. Now let me ask you this… Does this have anything to do with Admin rights? Because using ace permissions in server.cfg, doesn’t detect any admins. I’m thinking it is because without the STEAM API Key, it is not detecting the steam identifier, at least that’s the error I get.

EDIT: Finally, yes, so it does have something to do with Ace/Admin permissions because without the STEAM API Key, it couldn’t detect the steam identifier of the user… Excellent! Now, all I need is some information for Q2 listed below… How to add multiple users’ STEAM API Key, whether it requires a new line or can it all be added to the same line.

Q. #2.
If I want to add multiple users’ keys, how can I do that? Do I have to add a new line for each?

Example: set steam_webApiKey “MyKey”
set steam_webApiKey “another user keys”
set steam_webApiKey “Another User”

Or do I have to add it all in the one where my key is and not add a new line?

EDIT: Tested myself instead of being lazy and waiting for a response. I found out that you do, in fact, need to add a new line for each member you plan to add. If you’re having any Admin related issues, then this is the way to solve it. Of course, first, you’d need to set the ace permissions/admin stuff in your server.cfg, and then make sure to set steam webAPIKeys for each of your admins as well. If they do not have it set up, have them set it up using the tutorial from OP. Once you add the identifiers, and then set the correct Steam Web API Keys, you’re good to go! Should solve your issues.


1 Like

You can add essentialmode resource to your server (make sure it’s up to date) and working properly. When you have that you can go a head and remove those set steam_webApiKey "KEYS" and everyone should be able to join the server without steam :slight_smile:

1 Like

where is the file to edit the key?

Hey, is it possible to decline trade offers with this program?


What does the Steam Web Api key

Everytime I put the key in and restart the server the key will dissappear from the config file… Does anyone know how to fix this?

after i put the api key on server.cfg
then i restarted the server it diverts back to underfined
any solution to this?

1 Like

i can’t get the key, steam say this, why?
You will be provided with access to the Steam Web API Keys when you have games in your Steam account.

same happened for me too. i dont know how to fix it

how did you disable steam auth?

It says You will be granted access to Steam Web API keys when you have games in your Steam account.

image what’s wrong here

Is there a way to connect to my localhost without using a Steam API key?

I can’t generate a Steam API key because I don’t buy any games

(and no, i’m not going to purchase nothing)