Unknown component adhesive error when "adhesive" is removed from component.json

Environment questions

GTA V version: 1.0.2245.0
Up to date: Yes
Legit or Pirate copy: Legit
Purchased where - Steam/Rockstar Launcher/Epic: Steam
Windows version: Windows 10 - 20H2 (OS Build 19042.928)
Did you try to delete content_index.xml and try again? Yes
System specifications: Ryzen 7 5800X, GTX 1060 6GB, 32GB Ram
CitizenFX crash zip file (‘Save information’ on a crash): https://puu.sh/HDRWx/277878fb04.zip
logs/CitizenFX_log files:

[ 0] [ DumpServer] 20476/ DumpServer is active and waiting.
[ 0] [ FiveM] MainThrd/ — BEGIN LOGGING AT Tue May 4 14:20:04 2021 —
[ 32] [ FiveM] 21576/ Detected NVIDIA Node, attempting to query ShadowPlay status…
[ 188] [ FiveM] MainThrd/ Error: Unknown component adhesive.
[ 2172] [ DumpServer] 7108/ Process crash captured. Crash dialog content:
[ 2172] [ DumpServer] 7108/ FiveM has encountered an error
[ 2172] [ DumpServer] 7108/ Unknown component adhesive.
[ 3204] [ DumpServer] 7108/ Crash report service returned si-

.dmp files/report IDs: si-

If you can’t start the game at all

GTA V folder screenshot:

GTA V/update/x64/dlcpacks screenshot:

Filepath to FiveM folder:
C:\Users\XXXX\AppData\Local\FiveM

FiveM client folder screenshot:
image

Which antivirus/firewall software are you using?
Windows Defender + Malwarebytes

Did you try to disable/uninstall your Anti-virus?
Yes

Important parts

What is the issue you’re having?
Unknown Component Adhesive error while launching FiveM with ‘adhesive’ removed from component.json.

What are you trying to do?
Attempting to launch FiveM with ‘adhesive’ removed from component.json and connecting to a localhost server with svadhesive disabled & sv_lan 1 as I have received a 2 weeks global ban.

What have you tried already to fix the issue?
Updating windows to latest version, Re-installing GTA V from steam, Deleting content_index.xml and relaunching FiveM again (which worked fine) and then proceeding to remove “adhesive” from component.json.

Error screenshot (if any):
image

What did you do to get this issue?
launching FiveM with ‘adhesive’ removed from component.json from this guide:

What server did you get this issue on? Be specific and name some, ‘all of them’ by itself isn’t useful!
localhost was the last server I was connected to before receiving the global ban (adhesive and svadhesive was enabled during that time)


Additional comments

Background context:
I was learning how to develop C# scripts on my localhost server, while at the same time, also customizing my own character with vMenu. However, as I had Make Visuals Great Again installed my graphics mod, night times in the world would became pitch black and I was unable to get a clear visibility of my character.

I then added vSync (v1.4.0) | Simple weather and time sync to my server in an attempt to change the server time to day at the tip of a chat command. However, I ran into quite a few issues with vSync (Mainly with permissions) and after messing around for hours, I still didn’t manage to get vSync to change the time in my world.

Out of frustration and impulsive decision, I decided to attempt to inject a third-party mod menu into FiveM to try and get a quick and dirty way of being able to change the weather and time. And since I was playing on a localhost server at the time, I didn’t think to much about the consequences or aftermath.

A few hours later, I gave up on attempting to change the weather and customizing my character and just decided to go ahead with playing around with C# scripts. Only to find myself receiving the following message while attempting to connect to my own server:

I was drawn back abit when I first got that message, but ultimately didn’t really wanted to write a forum post asking for the removal of my ban as I know that I’ve messed up.

After looking around on the forums for abit, I came across a couple of posts, particularly this one on how one was able to still connect to their own localhost server while banned: Banned. What to do for 2 weeks?

Following the reply instructions, I had no issues with starting the server without svadhesive, however when I tried to launch my FiveM client after removing “adhesive”, in components.json, the above error was what I received.

I honestly don’t mind sitting out the 2 weeks ban as I know that it was entirely on me and the consequences of my own actions. However, it would be nice if I could at least still connect to my own server so I can continue learning how to develop scripts and messing around on my own.
(I’d even like to disable adhesive on my client from here on out as I do not wish to trigger another anti-cheat for whatever reason (Windows updates, Game Updates, other shady programs out there, etc, etc), as I hardly play on community servers anyways).

That said, any help would be greatly appreciated and thanks in advance~

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

You need the FiveM.formaldev file

Hi d0p3t,
May I know what is this FiveM.formaldev and where can I get it
Thanks~

An empty file. Just create it FiveM.exe.formaldev

Don’t remove it there, just delete the .dll file.

:rage: :face_with_symbols_over_mouth: :rage:

Hm - what’s with the anger, and why are you posting on someone else’s topic? :open_mouth:

Thank you for the suggestions, I will try them out once I’m home~

Ok so I Just got home and after testing out on some of the suggestions here, I was able to connect to to my local server again~

I’ll share my findings below and what I did to get it working again for anyone else in the future that might be in the same situation as I was.

Here’s what I tried first:

I tried adding “FiveM.exe.formaldev” under

C:\Users\XXXX\AppData\Local\FiveM\ and C:\Users\XXXX\AppData\Local\FiveM\FiveM.app\
but it still resulted in the same error above after removing "adhesive", from components.json

The solution:

I added "adhesive", back into my components.json, saved it, and instead, tried the following suggestion:

I ended up re-naming adhesive.dll to adhesive.dll.bak to disable the .dll without having to delete it, in case I wanted to join community servers again in the future after my ban.

Doing this allowed me to launch FiveM again.

However, this time I was met with a new error while attempting to join my server:

This was easily solved by disabling banlist from the txAdmin panel:
1 - Under Settings:
image

2 - Player Manager:
image

3 - Switch Enable Banlist to OFF:
image

4 - And then Saving it:
image

5 - Re-Connect to my server again in FiveM and Voila!:

Thank You to d0p3t and deterministic_bubble for helping me out and spending their time to provide suggestions~