Turning off vMenu Voice Chat, Forcing Mumble VoIP

I’ve seen a few people having issues where vMenu takes over in-game chat, instead of using Mumble VoIP, here’s how to disable vMenu’s voice chat permanently, as well as disabling it for server admins as well.

You can use any code editor I recommend Visual Studio Code or Atom, but you can use your preferred editor.


Setting Up Permissions Directory in server.cfg.

Setting Up Permissions Directory
exec /vMenu/config/permissions.cfg

Or if you have it in a certain directory, here’s an example of that.

exec /[resource folder]/vMenu/config/permissions.cfg

Turning off Permissions

1. Open up permissions.cfg in vMenu

2. Go to code line 512

3. Where you see add_ace builitin.everyone "vMenu.VoiceChat.Menu" allow should look like this here #add_ace builitin.everyone "vMenu.VoiceChat.Menu" allow now this should look like this below.

This will disable voice chat entirely for vMenu, and should let Mumble VoIP work correctly. If your still having issues, feel free to comment and I’ll help out the best I can.
Raccoon

2 Likes

Hi it doesn’t work :confused:
For me I tried and disabling it from menu but dont work I need to stop the resource

Hey @KOKOROG, I seen another setting @send1tsyko did you can also try this, by putting it in your server.cfg under exec resources/vMenu.config/permissions.cfg

add_ace builtin.everyone "vMenu.VoiceChat.Menu" deny
add_ace builtin.everyone "vMenu.VoiceChat.All" deny
add_ace builtin.everyone "vMenu.VoiceChat.Enable" deny
add_ace builtin.everyone "vMenu.VoiceChat.ShowSpeaker" deny
add_ace group.moderator "vMenu.VoiceChat.StaffChannel" deny

If this still does not work please let me know. :slight_smile:

Raccoon

I maked and that but dont work

Are you sure you didn’t mistype anything somewhere?

Yes I tried and reinstalling it

and a # in the front of the code and that will force stop it

1 Like

all the 2 options doesn’t work for me ;(

You’ve added vmenu perms to your server.cfg file. Right?

`exec permissions.cfg`

i have add that

and # doesn’t work for all the phrases of Voice chat

Where do you have your vMenu permissions saved at?

I left my vMenu perms where it’s at, and just did this.

exec resources/[Scripts]/vMenu/config/permissions.cfg

we have permissions set in Server-data folder :wink:

in the same folder as server.cfg


Screenshot_16
i got this errors

and when i push to talk button this cames in my screen.
Screenshot_17

he takes the keybinds out of the file, that works!, but they don’t stop voice-chat
@TheRaccoon

If your getting that error, you either mistyped somewhere, or you need to go from “/” to " \ " if your running a Windows VPS, I always use Linux so for me it’ll be “/” to get the file.

The problem is solved with downloadiung the newest version of Vmenu

1 Like

Thank you.

1 Like

can i pleas get help i have tried all of this nothing is working this is all i need before my server goes live

Shoot me a DM, and I can help you out after work, or tomorrow.

i have same problem and i do all steps and download the last version 3.3.1v