Stuck IPFS discovery

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version?
Up to date? Yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Steam
Windows version? Windows 10
Did you try to delete caches.xml and try again? yes
Error screenshot (if any)
System specifications
What did you do to get this issue?
What server did you get this issue on?
Latest CitizenFX_log file
.dmp files/report IDs

If an issue with starting:
RDR2 folder screenshot
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Did you start Rockstar Games Launcher not as admin?

Also add what you already tried so far.

It’s my first time installing RedM and i have a problem, because i got stuck on the moment when it’s IPFS discovery, and it’s not going any further, I left my PC for about 2 hours and nothing changed, I don’t know what should i do. Please help.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Same problem. Why no answer yet?

fixed this by changing your IPV4 DNS to
opendns ips
Primary 208.67. 222.222
Secondary 208.67. 220.220

Cloudflare dns work as well 1.1.1.1

but after it downloaded now im getting a Kernelbase.dll+2D759 error
which I have not a foggy clue how to fix this?

Crash dump CfxCrashDump_2021_02_12_00_59_12.zip (98.1 KB)

It got past this and is now hanging downloading game cache. Holy hell how is your average Joe supposed to figure this out? DNS? I just want to download the files from a reliable source.

Do you want to Know how to change your DNS?
@running_red_fox
make a change to your DNS is safe.
it just change how your computer resolves to a site or endpoint.
you don’t change any firewall setting’s so your computer still protected.

Windows 10

Control Panel - Network and Internet - Network and Sharing Centre - Change adapter Settings-

Then right click which ever one your PC uses to connect to the internet. Ethernet for wired connection to your pc or WIFI if your using wireless.

properties - Internet Protocol Version 4 (TCP/IPV4) - properties -
click (use the following DNS servers addresses) - (Preferred DNS Server): 208.67. 222.222

Yeah tried this but when pasting that IP adress i could not because that ip was “malformed”

Hi I am having the same issue. I have tried a VPN both enabled and disabled, I tried changing my DNS servers, and I tried a whole different internet connection to no avail. Are there any other solutions or is the file host offline or something?

Same problem going on.

Have tried, VPN (made sure VPN supports P2P), DNS change, full reinstall of RD2, Virus Scan Down, Firewall down, even tried reinstalling windows fresh. Something is off here. Going to let it run over-night just to see but I doubt it will do anything.

I too am running, legit version, up to date, Steam, Windows 10, deleted caches. Fully out of ideas at this point.

Would like to also point out that I used to have RedM installed and running, have uninstalled and reinstalled it in the past days without any problems. (last time about 2 days ago)

did someone fixed the problem?

no luck here, it has been running for hours…

It is now working everyone! 2:06 AM EST

Anything you did? VPN, DNS, etc? Did it just start working, or did you change something? Were you trying multiple times, did you just leave it running?

It’s not working yet on my end.

I did nothing. It just started to work eventually after restarting it went instantly eventually…

Having the same issue

Every time I download RedM, it’s always something! I just wanna jump in one of those RP servers but now I’m getting the same problem to where it was stuck on IPFS Discovery, I installed Proton VPN and it actually started to download but very slowly and only downloaded a quarter of a gig out of roughly 4gb I believe before freezing the download!

I did find that closing the connection to the server your trying to connect to then reconnecting to the same server resumes the download where it left off until it freezes again. Also the every time I restart the connection to the server, the download size increases dramatically. It was roughly 4gb and now its roughly 24gb and only increases every time I restart. How is it there are people playing but there’s also a majority having the same issues, What are the people that are playing doing right?

Yes, closing the connection and reconnecting worked but only a few times, eventually it would get stuck permanently, for me it was at 45%. I deleted cache, started all over again (again) and got it to get to 60% before being permanently stuck. Im also wondering how anyone is able to play at all like this.

i tried connecting to a server with 32 player max and had no problems, so im wondering is this a problem with servers with more than 32 players

are you having trouble connecting with only some servers?