[Release] [RedEM: RP] Stable System

RedEM:RP Stable 1.0

Version: 1.0.0

GitHub: https://github.com/Luminous-Roleplay/LRP_Stable

You can buy & customize horses
You can name your horses
You can Sell your horses in the stables menu
You can buy for Dollar or Gold

Requirements

RedEM:RP
RedEM:RP Identity
RedEM:RP Respawn
RedEM:RP Inventory

Preview

Hey, I’m getting an issue.

Adding the SQL says:
Error Code: 1101. BLOB, TEXT, GEOMETRY or JSON column ‘components’ can’t have a default value

But when I remove the default value, and then try to buy a horse, I get a console error saying: ERROR: components does not have a default value.

I know this should be simple but can’t figure out what to do lol

Can you send me print?

I added it ot my resources and when i tried to start the server, i got the following error: Assertion failed: m_marks.empty() (…/…/…/components/citizen-server-impl/src/ResourceFilesComponent.cpp: ~MarkedWriter: 22)
any idea?

This has no relation to the stable

Its strange then. Without the stable resource my server starts just fine, but after adding it to the resources, i cant start it all, have the same error

For me, the stables arent working properly, the preview of the horses doesn’t show up and then I cant exit the menu


This is the error I’m getting.

image

#1101 - BLOB, TEXT, GEOMETRY or JSON column ‘components’ can’t have a default value

Try import this on SQL

CREATE TABLE IF NOT EXISTS `horses` (
 `id` int(11) NOT NULL AUTO_INCREMENT,
 `identifier` varchar(40) NOT NULL,
 `charid` int(11) NOT NULL,
 `selected` int(11) NOT NULL DEFAULT 0,
 `model` varchar(50) NOT NULL,
 `name` varchar(50) NOT NULL,
 `components` text NOT NULL,
 PRIMARY KEY (`id`),
 KEY `FK_horses_characters` (`charid`)
) ENGINE=InnoDB AUTO_INCREMENT=27 DEFAULT CHARSET=utf8mb4;

You are using the old version, try downloading again

I get this error when trying to load the .sql file. (“zap600579-1” is the username assigned to me by the server host.)

SQL Error (1044): Access denied for user 'zap600579-1'@'%' to database 'redemrp'

And the failed loading of the SQL file led to this in my live console:

[ERROR] [MySQL] [LRP_Stable] An error happens on MySQL for query "SELECT * FROM horses WHERE identifier='steam:110000105c8baaf' AND charid=1;": ER_NO_SUCH_TABLE: Table 'zap600579-1.horses' doesn't exist

Any ideas? Am I missing a password somewhere or something?

It doesn’t appear to be locating your database

Yeah, I know that. But why? I have no problem importing other .sql files.

Ok, I figured out the SQL problem, but now when I enter the stable and open the store, no menu shows up and I have to use my Task Manager to close the game because it gets stuck. Someone else also had this issue and posted it on the github.

I just fixed the problems

1 Like

I started the resource on windows localhost and it does not says the error, but when i start it on my zaphost linux server, it crashes immediatly. probably the linux server version is not compatible with the resource, right?

I can’t say, I never used linux. But there should be no problem. Try to download the script again, I made updates

Problems not fixed. Still can’t access the menu and my character gets stuck and I have to Task Manager out of the game.