[Release] RC-Mining Job | ESX Framework

Hello community! Today I’m going to show you my mining job script. This script is also part of a slightly larger project but that will come out a little later. So be patient!

Functions

  • Randome mining spots
  • Chance of iron or gold
  • Pickaxe can break
  • Opportunity for more resource by mining

Configs

  • Configurable mining spots
  • Configurable refresh mining spots time
  • Configurable NPC Hash

Preview

https://youtu.be/ZB5Cz39mPy4

Download

MinerJobRC.rar (374.4 KB)

That’s it for my side. I would be happy if you leave feedback. Have a nice day and stay healthy! :slightly_smiling_face:

12 Likes

I will try, but it looks beautiful and with quality.

1 Like

whats this ‘@rc_joblevels/server/main.lua’,?

I’ve added this line to the fxmanifest for later. This script, which is currently being accessed, is not a mining job

a level system right?

Yes right :wink:

Question, How do we open the mine up?

Sorry I forgot to add it. Either you install an open mine map yourself or download my new version

Cheers bud

1 Like

Is there a Job sql?

No is a freetime job

can any one help me with this?
SCRIPT ERROR: @rc_minerJob/server/main.lua:42: attempt to index a nil value

Check if u have the item “pickaxe” in ur inventory

I have same bug report… I have it in inventory. I have it in db…

Can’t close the Shop UI, i get stucked.

Edit:

I fixed at a least the menu opening, but there is still some problem, im not able to buy or sell anything.

if distance2 <= 1 and IsControlJustReleased(0, Keys["E"]) then
			if isMenuOn == false then
1 Like

i have added the files to my resource folder and have added them to my server.cfg but it cant find the resource rc_minerjob? any help would be appreciated

i sorted it, had to rename the resource to rc_miner and it worked :grinning:

i have the same problem, but i tried putting what u have sed and it broke the script