Keymaster: Could not resolve the IP specified

Whenever I try to generate a new key using my own IP, I get the error “Could not resolve the IP specified”. I’ve already confirmed that I’m using the correct public IPv4 address. Any idea what might be causing this problem? Thanks.

1 Like

u might be putting a ipv6 which doesnt work with fivem to know this does it look like this 2X01:XXX:82X0:Xbd0:3XXX:XXXf:8XXc:XXX9

Nope, I’m definitely putting in an IPv4.

put pics of ur server files and check if the code is active

The issue I’m having is with actually generating the key on Keymaster, not running the server.

I am also having the same trouble. I’ll generate a key but it says could not resolve ip. I even contacted my isp to see if they blocked anything. That was not the case sadly.

Can we know what ip you are trying it with?

Personnaly, I’m trying with local IP (127.0.0.1 and 192.168.1.15)

That is a loopback address and a private ip address, try your actual external ip address. (e.g. google “what is my ip”)

Okay still having the same problem. I am using my public IP address.

Can you still host a 5m server from home?

Having this same issue with my ip trying to make a key. ip is hosted from a data center called joes data center. ip is

Could not resolve the IP specified (204.27..*).

I figured out that it’s my ISP (I use spark light). I registered my home public IP and it gave me could not resolve IP. I asked my friend to register his public IP Address and it worked ( he uses AT&T as his ISP). So I tried to register my companies public IP and it didn’t register ( company uses spark light). So that ruled out my problem. I’am in the process of switching to AT&T fiber which I was already doing. So I assume some ISP’s block you from assigning licenses to your IP. Hope this was some help. Just a note: It could be a dns problem, so try switching to 8.8.8.8 (google) or 1.1.1.1 (cloud flare). Also I don’t know this for a fact, but it could have to do with dynamic and static IP’s.

I ended up getting an entirely new IP from my ISP (it was actually the result of solving another issue I was having with them) and I’m still getting the exact same “Could not resolve the IP specified”. Does anybody know what might be causing this?

Keymaster relies on Whois look up to provide a key for you. Keymaster has to authenticate the host name. Sometimes your ISP provides “weird” Whois results, resulting in “Could not resolve Ip 24.xxx.xxx.xxx). I short terms Keymaster can’t authenticate your IP. So ultimately it comes down to your ISP. I have tried proxy servers, vpns, new Ip’s. So it depends on how bad you want to host your own server. The only way I KNOW is to change service providers. It’s not a big deal, but pricing and speed can be different. I switched to at&t. No problems so far. Hope this helps. @

Hey i tried everything and it still didn’t work have any more tips

Are you willing to get a new internet provider like at&t? If you are that’ll fix your problem.

I am having a similar issue but with a proper public IP address and it appears to be EVERY IP in our IP address range :cry:

im having the same problem

Check my post, might have a solution coming down the line soon if you are getting a similar WHOIS result as mine…