[ESX Legacy] ESX Multicharacter

Did you find a fix for this?

Do you use the updated one and secondly did you change esx skin or skinchanger etc.

both esx skin and skinchanger has been updated to the one that goes with Legacy. I haven’t changed anything else i’m aware of.

Multicharacter can cause problems on certain scripts which try to load your username when you connect to the server, except this is defined once the character has been selected. And not at the time of connection. You just need to fix it by telling the script to load only after the players have loaded.

If once your character loads, and a restart of your script which at beug everything works fine then you have found the problem. I was able to experiment it especially on the display of clothing and accessory own which was loaded at the connection to the server and not after the selection of the character.

Peace :slight_smile:

I got it all sorted in the end, I ended up changing over to TXadmin and starting the server fresh.

Thanks for your help though, hopefully it will be useful to someone else :smiley:

Cheers.

I keep getting this error.
[esx_multicharacter] An error happens for query “SELECT identifier, accounts, job, job_grade, firstname, lastname, dateofbirth, sex, skin, disabled FROM users WHERE identifier LIKE ? LIMIT ? : [“char%:6d52646bcf86ed12d0c977e5160d8f7fea7b903e”,4]”: ER_BAD_FIELD_ERROR: Unknown column ‘accounts’ in ‘field list’

You’re missing a column from ESX in your database, so check into that. :man_shrugging:

Im getting a black screen using overextended when loading. no error messages in console

Hello, I am wondering if you could help me further;
when I load the server up with only the scripts that are required and the dependencies of all scripts mentioned as per the Github page I seem to only get a black screen on FiveM, I cross-referenced all of your page and made sure all conflicts were disabled/removed entirely, however when I enable basic-gamemode it allows me to spawn in however it’s a weird view, click here to see what I get;

There is a couple of things that I could imagine could be the issue however I do not know how to resolve them;

Set your database name for Config.Database in server/main.lua

I am confused by this instruction, as the latest download has no Config.Database in the file as mentioned, maybe so clarification would be able to resolve this.

Seond point is, everytime I start the server up I get this wonderful error however I do not know how to fix it, any pointers would be appreciated - I am using all up-to date scripts from the esx-legacy folder, and double-checked everything.

[ script:mysql-async] [MariaDB:10.4.22-MariaDB] [ERROR] [esx_multicharacter] An error happens for query “SELECT TABLE_NAME, COLUMN_NAME, CHARACTER_MAXIMUM_LENGTH FROM INFORMATION_SCHEMA.COLUMNS WHERE TABLE_SCHEMA = ? AND (COLUMN_NAME = ? OR COLUMN_NAME = ?) : []”: ER_PARSE_ERROR: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘? AND (COLUMN_NAME = ? OR COLUMN_NAME = ?)’ at line 1

`

Are you using an old…er version of mysql-async that doesn’t support ? placeholders?

Hey, thanks for the quick response;
I am using the latest available release;

Well, what does DATABASE print out as, and what is your database? I’ve tested it with both URI and semicolon formats without issue, but some characters might not be accounted for. Using URI I assume?

You should know the name of your database, meanwhile print the value of DATABASE in esx_multicharacter after it gets set.

The alphanumeric string is your license identifier, and you don’t need to change anything; it just works. Tested it with default zap recipe installation like two weeks ago, with both mysql-async and oxmysql.

Complete full update;
I did a fresh install of each script, started from ground up and prioritized esx_multicharacter, personally I think it could be the order of the scripts start up within the .cfg file.

1 Like

I ended up finding a fix because i was using raid_clothes. So now it works.

i love this multicharacter system so far, i just have one question so i just came from 1.1 which is pretty outdated. i wanted to use an identity script i purchased already but the depended for this multicharcter is esx_identity how do i go about changing it to the on i have it as as that script name cant be changed to esx_identity? i really want to use both together