Unable to start RedM, it starts RDR2

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version?
Up to date?
Yes (Reinstalling it now)
Legit or Pirate copy?
Steam/Epic Games/Social Club?
Windows version?
Windows 10
Did you try to delete caches.xml and try again?
Yes, I have reinstalled the whole RedM and Rdr2
Error screenshot (if any)
System specifications
Processor - AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Memory - 16 GB
Graphics - RX 5500 XT 8GB
Storage - M2 1TB-SSD 500 GB -HDD 500GB
Windows Windows 10 Home 19045.2728
What did you do to get this issue?
I was usually playing, but one day, I clicked F8 > quit, and then when I tried to go back into the game, it did not work anymore. I click on RedM, but afterwards, RedM does not open fully( like 1/4 of the screen), and it opens RDR2. I can see RDR2 playing in the background ( on the other 3/4 of the screen), and it does not start RedM at all. I have installed and reinstalled RedM and RDR2 without success. Now I am reinstalling Steam with RDR 2, hoping that will work.
What server did you get this issue on?
Initially was Western Legends, but now I cannot play to any server, as when I start RedM it starts RDR2
Latest CitizenFX_log file
N/A (installed and reinstalled everything)
.dmp files/report IDs
N/A (installed and reinstalled everything)
If an issue with starting:
RDR2 folder screenshot
(Reinstalling it)
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Yes, I did.
Did you start Rockstar Games Launcher not as admin?
Yes, I did.
Also add what you already tried so far.
I have installed RedM and reinstalled it from redm.net. I noticed that RedM was installed to my download folder in C drive, however, when I tried to launch redm it asks me to select the .exe, which I did, and when I start RedM it starts RDR2 automatically. SO I have tried to uninstall and reinstall RDR2 from Steam, and this morning I have noticed that did not bring to me any success. I have installed Steam and reinstalling RDR2, hoping this will change the things.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!