Stuck on City Screen, HELP

Before you begin, please read the Client FAQ and Common Questions topic.

RDR2 version?
Computer / Latest

Up to date?

Legit or Pirate copy?

Steam/Epic Games/Social Club?
Steam/Social Club

Windows version?
Windows 11 Home 21H2

Did you try to delete caches.xml and try again?

Error screenshot (if any)

System specifications
Intel(R) Core™ i7-8750H 16.0 GB

What did you do to get this issue?

I changed from Vulkan to Direct X and now I get stuck on this screen.

What server did you get this issue on?

Latest CitizenFX_log file
CitizenFX_log_2022-07-15T104456.log (60.6 KB)

.dmp files/report IDs

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder

RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus?
yes, windows defender

Did you start Rockstar Games Launcher not as admin?

Also add what you already tried so far.

  • VPN is always disabled. I use NordVPN.
  • I’ve reinstalled both RDR2 and REDM.
  • Disabling Firewall
  • deleting cache, server cache + priv server cache


remove %appdata%\CitizenFX\rdr3_settings folders

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.