[Standalone] Recording Clips

Recording Clips

About

Recording Clips is a small standalone resource allowing players to record clips and use action replay while playing.

The default keybindings are as follows:
F1: Start/Save a recording
F2: Toggle Action Replay
F3: Cancel current recording
These can all be changed in the config file or by the individual players in Settings>Key Bindings>Fivem.

The rockstar editor can be accessed by doing /rockstareditor or by going into the pause menu.

I decided to release this because I was unable to find any other resource for FiveM that wasn’t a part of or required a menu and that had action replay included.

Showcase
Preview video (YouTube)

Optimization
The script runs at 0.0ms when idling. 0.02ms when displaying a tooltip.

Known Issues
The rockstar editor itself doesn’t seem to like models encrypted through the escrow system since the editor force disconnects you from the server. Thanks to @ThatOtherGuy for pointing this out.

Configuration
All of the text can be changed. You can see the config file below on Github.
Config file (github)

Download

Github
Direct download: recording.zip (58.0 KB)

My other scripts
[Standalone] [Paid] Sit Anywhere
[Standalone] [PAID] Slash Tires
[Release] Telescopes
[Standalone] Crutches

7 Likes

Such a great script, exactly what I was looking for! :+1:

Should let people know that this won’t work for escrow encrypted models (MLO’s, etc). Going into Rockstar editor is leaving fivem and escrow encrypted files require being in FiveM for them to load and will crash Rockstar editor.

Hm… While you most likely are correct about encrypted models not working with the rockstar editor you don’t actually leave FiveM, you just disconnect from the server.

I’ve removed the part where it force disconnects you by just opening the editor (trough the command), however, the game will still disconnect you when you attempt to edit/preview clips. Maybe this will make a difference? Most likely not tho.

Anyway, thanks for enlightening people regarding this issue, I can’t imagine how frustrating it would be to find that out after making a bunch of clips. I’ll add it to the post to let people know.

Capture
I get this everytime I go into the editor after recording and try to load a clip

Hm… do you have any encrypted models loaded on the server? There is not much I can do as far as I know, do you mind sharing some more information? How did you enter the rockstar editor? (trough the command or the pause menu?). Did you have any custom MLO’s/clothing/vehicles etc. in the scene?

When opening a clip it loads infinitely. any solution

This is a fivem issue, you wont be able to fix this and will have to wait for fivem to somehow save/remote-load the encrypted files or something to work with r* editor.