[Standalone][Free] VoiceRangeMarker

Hi there!

Just made/re made a small script for ■■■■ voip users or mumble users.

Its help to show how far is the voice going. You need to set it up. But in the config.lua you can set up everything what you need!

Pictures:
Picture[1]

Download

I can see there are some questions about config. I tried to write info everywhere…

Most questionable part is the Config.Height = 0.8* (Z value is the middle of the ped minus what you write here)

P.S.: First real topic+first uploaded script so be patient and if you have more ideas just please write it to me:)

8 Likes

Your link is broken! there is an extra https:// ! also there are no pictures :frowning:

Use this link until he fixes it

2 Likes

Worked for me xD

I merged this with a scripts folder I have which has many small script such as this. Less resources loading up in my city. So far so good.

1 Like

im not saying it doesnt work im saying the download button has an extra https://

1 Like

And I’m saying his link worked for me as I downloaded it before you even made a post…

1 Like

Fixed download link. Please proof your topic after you made

But umm, apart from this being for voice, period (it has literally nothing to do with another resource or third party plugin :face_vomiting: ), the marker will 100% flicker. Have you tested this?!

It was working when he first posted, I think he broke it when he went to update it with pictures, good looking out to the both of you though.

I’m using it atm and I haven’t had that issue. I made the time it’s visible set to 5 sec instead of 10 and I raised how high the marker is. Maybe that will fix it.

It doesnt show the marker for me, has it something to do with that I’m using saltychat?

This literally works with everything. I don’t know why it says it’s made for that one voip script thats deprecated and “mumble users”. It literally works with FiveM, period.

I think you don’t see a marker because the thread that’s supposed to draw it runs every 5 ticks, which means you will only see it every 5th tick which can be “never” if your FiveM is running slow

how you mean running slow? i dont have a bad computer :smiley: It doesnt show anything for me.

Try this: in the script, change the Citizen.Wait(5) to a 0.

still not showing

Shift + Z is default settings to get it show. If you only use 1 key to change your voice proximity then remove the second keymapping in the client.lua.

The resource runs fine for me. No issues at all. But my server is highly optimized and it runs on a Ryzen 5 3600, 32GB ram, & 1GB download/upload.

What do we put if there is no second key to press? I can not get this to show up for the life of me.

if IsControlJustPressed(0, Config.FirstButton) then

Edit line 8 to that ^^^ (client.lua)

Config.FirstButton = Config.Keys[“Z”]

(config.lua) ^^^
This is what I have it set to as Z is what I use to change my voice proximity for my voice script.

I use key ID 243 for voice changing but tried your edit now too and still it doesnt show me anything.

Don’t use numbers, use the actual key name itself.

yeah i did i used this: Config.FirstButton = Config.Keys["~"] but it doesnt work. it doesnt who me any markers