SimplePassive: Passive Mode in your FiveM server, just like in GTA:O

SimplePassive is a resource for FiveM that allows you to use a Passive Mode like feature just like in GTA Online.

It has multiple configurable features that you can configure and use, like:

  • Authorizing specific players via ACL permissions (for example: only staff members can use passive)
  • Forcing passive mode onto players (to prevent harassment or ramming with vehicles)
  • Disable combat between players (for the true passive mode experience)

Just like my other resources, SimplePassive has exports that other resources can use for controlling passive mode. With this, you can do stuff like adding a toggle on a menu or enabling passive on certain user interactions.

Download:

Installation: https://github.com/justalemon/SimplePassive#installation
Usage: https://github.com/justalemon/SimplePassive#usage
Source Code: https://github.com/justalemon/SimplePassive (under MIT License)
Feature Requests & Bug Reports: https://github.com/justalemon/SimplePassive/issues
Full Changelog: https://github.com/justalemon/SimplePassive/releases

16 Likes

nice! where inside do you add permission for yourself? I think this is a really good idea to prevent hackers from exploding players. I have a constant full server, and hackers join and blow my players up. If I could add this to all players with one command to prevent a hacker from doing this, this script would be amazing.

1 Like

exacltly

I’m trying to answer but the message ends up flagged for manual approval.

can you message me the answer?

SimplePassive uses ACE Permissions, you just need to use the standard syntax. For example, this will allow a player with that Discord ID to use passive:

add_ace identifier.discord:000000000000000000 simplepassive.changeself allow

The best you can do for now is to set an override to enable passive with combat disabled on the clients of those using “the bad programs”.

If someone is using natives directly, then you are out of luck.

Are you using an up to date FXServer build?

Yes, I am.

SimplePassive uses fxmanifest.lua instead of __resource.lua. Something is somehow trying to load the old metadata format.

The resource was compiled for 2328 on both Client and Server, so make sure that you are at least using 2328.

This is wrong. It should be:

add_ace builtin.everyone simplepassive.changeself allow
1 Like

Suggestion : config a keybind instead of command

1 Like

There is no reason to. Passive Mode is something that should not be changed constantly.

Nice work dude !!

20char

Invisibility doesn’t work.

What is exactly going on over here? Who is player one? What players have passive enabled? Have you changed any convars? What does the debug information says? (setr simplepassive_debug 1)

What did i do wrong

In server.cfg I just added

add_ace builtin.everyone simplepassive.changeself allow

setr simplepassive_debug 1

Can open and can punch each other

is this fixable? it cause by that half invi thing. happen also if used noclip in vmenu since it have the same half invi effect. image below showing that he is not in passive