[Release] mumble-voip, rp-radio

same to me

do you possibly have vMenu installed, or another voice script like esx_voice?

I cant Join on privat channel.

ESX.UI.Menu.Open('default', GetCurrentResourceName(), 'cloakroom', {
		title    = _U('cloakroom'),
		align    = 'top-left',
		elements = elements
	}, function(data, menu)
		cleanPlayer(playerPed)

		if data.current.value == 'citizen_wear' then
			if Config.EnableNonFreemodePeds then
				ESX.TriggerServerCallback('esx_skin:getPlayerSkin', function(skin, jobSkin)
					local isMale = skin.sex == 0

					TriggerEvent('skinchanger:loadDefaultModel', isMale, function()
						ESX.TriggerServerCallback('esx_skin:getPlayerSkin', function(skin)
							TriggerEvent('skinchanger:loadSkin', skin)
							TriggerEvent('esx:restoreLoadout')
						end)
					end)

				end)
			else
				ESX.TriggerServerCallback('esx_skin:getPlayerSkin', function(skin)
					TriggerEvent('skinchanger:loadSkin', skin)
				end)
			end

			if Config.MaxInService ~= -1 then
				ESX.TriggerServerCallback('esx_service:isInService', function(isInService)
					if isInService then
						playerInService = false

						local notification = {
							title    = _U('service_anonunce'),
							subject  = '',
							msg      = _U('service_out_announce', GetPlayerName(PlayerId())),
							iconType = 1
						}

						TriggerServerEvent('esx_service:notifyAllInService', notification, 'police')
						exports["rp-radio"]:RemovePlayerAccessToFrequencies(1, 2, 3)
						TriggerServerEvent('esx_service:disableService', 'police')
						TriggerEvent('esx_policejob:updateBlip')
						ESX.ShowNotification(_U('service_out'))
					end
				end, 'police')
			end
		end

		if Config.MaxInService ~= -1 and data.current.value ~= 'citizen_wear' then
			local serviceOk = 'waiting'

			ESX.TriggerServerCallback('esx_service:isInService', function(isInService)
				if not isInService then

					ESX.TriggerServerCallback('esx_service:enableService', function(canTakeService, maxInService, inServiceCount)
						if not canTakeService then
							ESX.ShowNotification(_U('service_max', inServiceCount, maxInService))
						else
							serviceOk = true
							playerInService = true

							local notification = {
								title    = _U('service_anonunce'),
								subject  = '',
								msg      = _U('service_in_announce', GetPlayerName(PlayerId())),
								iconType = 1
							}

							TriggerServerEvent('esx_service:notifyAllInService', notification, 'police')
							exports["rp-radio"]:GivePlayerAccessToFrequencies(1, 2, 3)
							TriggerEvent('esx_policejob:updateBlip')
							ESX.ShowNotification(_U('service_in'))
						end
					end, 'police')

				else
					serviceOk = true
				end
			end, 'police')

			while type(serviceOk) == 'string' do
				Citizen.Wait(5)
			end

			-- if we couldn't enter service don't let the player get changed
			if not serviceOk then
				return
			end
		end
PlayerData = ESX.GetPlayerData()

                  local inventory = ESX.GetPlayerData().inventory

                  local hasradio = nil

                  for i=1, #inventory, 1 do if inventory[i].name == "radio" then hasradio = inventory[i].count end end

                      if hasradio == 0 then

          exports["rp-radio"]:SetRadio(false)

                      else

          exports["rp-radio"]:SetRadio(true)

                      end

So i am using mumble, and i am also using an external hud. But there is no export to check voice mode, check if player is talking etc. How do i make those?

Hi does anyone know how to fix this? I followed a video on how to install, both are latest versions possible too and ive tried various versions, re installed etc …

I can bring the radio up by using the keybind / typing /radio and you hear the click when you connect to a frequency but you cant talk in the radio and of course you cant even talk in general using whisper, normal or shouting due to whats being shown the image below bottom right…

Read bottom right it is not connected and can’t be read top of topic post to get another resource

Turns out I didnt have one sync enabled on my TX Admin so I turned that on but its only fixed half of it.

Its connected and I can use my radio now but it still says Mumble initializing bottom right so cant use the general voice chat to talk in game. And ive tried alot but nothings fixing that its weird

I can’t turn on the animation when talking on the radio, any suggestions?

People have been asking me if i could change it so when they walk with controller it doesnt pop up the radio in their hand. Was just wondering if there is a fix

Hey, I’m wondering if there is a way I could lock radio channels 1-4 behind the ace permissions group “leo”, I have a pretty limited knowlege of actually creating scripts or adding things on so wouldn’t really know where or how to start

how to disable speak while dead ?

Do i put that in server.cfg?

can you send me your mumble voip and radio files, mine are not working so could i try yours?

Not connected to mumble, how can i fix this. And yes i have onesync infinity enabled

Hello, I installed it, and working well. But How do set up it to work when calling somebody?

Vmenu voice needs to be disabled.

do i have to buy FiveM Element Club Aurum :dvd: I have FiveM Element Club Argentum :cd: already I have used all the synce and tried multiple vc so do I have to buy the 32$ pateron to use that?

I don’t think FiveM Element Club Aurum is really that much of need for mumble-voip. Argentum is more than enough I think. Some servers are using mumble-voip without patron(somehow :confused: ) So I would say you don’t need to waste your money.

How do I use it cause I’ve tried everything?