Redm wont update from internet for me to install

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version? not sure how to even find this but its fully updated on steam
Up to date? yes
Legit or Pirate copy? legit
Steam/Epic Games/Social Club? steam
Windows version? yes i think so
Did you try to delete caches.xml and try again? yes
Error screenshot (if any)

System specifications not sure how to even get those
What did you do to get this issue? tried to install redm
What server did you get this issue on? not on a server
Latest CitizenFX_log file
CitizenFX_log_2023-09-17T213150.log (190 Bytes)

.dmp files/report IDs ? idek what this means

If an issue with starting:
RDR2 folder screenshot
RDR2/x64/dlcpacks screenshot
Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus?
Did you start Rockstar Games Launcher not as admin?

Also add what you already tried so far. havent tried anything other than deleting it and redownloading it to try installing it and tried to make a ticket and they took me to ur discord which said im not even promised support and to make one here so thats what im doing

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!