RedM crashes after it says i need to update my cache when i try to join a server

RDR2 version? 1.0.1355.23
Up to date? yes
Legit or Pirate copy? legit
Steam/Epic Games/Social Club? social club
Windows version? windows 10
Did you try to delete caches.xml and try again? yes
Error screenshot (if any)crash capture
System specifications Gpu: nvidia geforce gtx 1060, CPU: intel i7 7700k, ram: 32 GB
What did you do to get this issue? tried to join a server which then RedM shows a screen that says i need a different game version and red m is downloading it. upon checking the update.rpf RedM shows another message that says it needs to update the game cache and as soon as i press the OK button it crashes
What server did you get this issue on? Wild west RP

Also add what you already tried so far. I’ve tried turning off the firewall reinstalling Redm and RDR2 and verifying the game files and also clearing my game cache files for RedM. Please let me know if there is any more information i can provide as well. I have also tried the fix specified on the forums here: [FIXED] RedM Crashes on Updating Cache and that did not work either

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: