Red Dead Crashed on Start Up (Parse Error line 1) Went to reinstall now getting a new error

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version? NEWEST
Up to date? YES
Legit or Pirate copy? LEGIT
Steam/Epic Games/Social Club? STEAM
Windows version? 10
Did you try to delete caches.xml and try again? YES
Error screenshot (if any)


System specifications
What did you do to get this issue? I DONT KNOW
What server did you get this issue on? REDM CLIENT
Latest CitizenFX_log file CitizenFX_log_2020-08-26T184937.log (1.4 KB)
.dmp files/report IDs
e2adbd2f-469d-4160-bffd-6be3135e4060.dmp (528.7 KB)

If an issue with starting:
RDR2 folder screenshot


RDR2/x64/dlcpacks screenshot NONE
Filepath to RedM folder INCLUDED WITH RDR2 FOLDER SCREENSHOT
RedM client folder screenshot 1st location, then 2nd location when i press open file location.
RedM folder

Did you try to disable/uninstall your Anti-virus? YES
Did you start Rockstar Games Launcher not as admin? LAUNCHED AS ADMIN

Also add what you already tried so far.

I reintalled Steam, Rockstar Game Launcher, Red Dead Redemption 2, and Red M.
I uninstalled my antivirus software. I deleted my cache, i cleaned my regristry out using ccleaner,
I deleted the rockstar game folder. When I try to download it again and update the cache process when red M tries to do the cache thing. I get the the Download Error (Steam Error?) Its posted up in my first screenshots. Thanks in advance…

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Same error here

exact same error i am having as well

the problem maybe is the steam location different to rockstar launcher directory ?

i have the same problem but my game is through epic gaming but mi still have steam open when trying to load game

I’m getting the same issue. I think it may be a issue with steam/epic not working with it, because everybody else I know that plays RedM bought it through Rockstar games and don’t have issues.

i have the same error

I was getting the same “Parse Error Line1” upon updating the cache and when trying to launch RedM. I went in to task manager and killed everything that Steam was running. Then logged in to Rockstar and launched RedM again, and I got in without any errors.

This was after hours of searching online to find a single Reddit comment that said to try this. Hopefully it helps some people

Edit: I’m able to get RedM up to the menu, but can’t connect to a server and play the game because ‘steam’ isn’t found. So I’m back to square one…

I’m getting the same error just installed RedM

I have been getting this error past couple days and tried clearing out all files related to RedM. Reinstalled RedM and still same error. I have used RedM before but was a few months ago and it was working fine then. Something has changed with an update that broke it.

I’m still looking for a fix.

Found a temporary work around here in another thread that does work but it is a pain to do every time you want to play RedM.

  1. Close Steam
  2. Start Rockstar Launcher
  3. Start RedM - Don’t click “start” once loaded
  4. Start Steam
  5. Click start In RedM

We need a better fix then this but it does work for now.

thanks for this solution,
it helped