[QBCORE] Keep-companion - qbcore pet system

a free companion script for QBCore, pets are stored as items inside your inventory, and after they are out, there is a menu to control them. owners should take care of their pets. (food, water, and health)

open the menu by pressing ‘o’.

The complete installation guide​ is available on Github.

Download

| Code is accessible | Yes
| Subscription-based | No
| Lines (approximately) | 2000 lines
| Requirements | QBcore/qbtarget
| Support | Yes

4 Likes

Thanks!!!

1 Like

is this script where u can buy pets too

yes, if your shop setup is the same as the installation guide and if players already bought pets they can transfer ownership.

Hi I don’t have pet shop do u kown any script for pets shop

qb-shops or any other shop script should work with the script if you convert config file correctly.

not sure how

If I knew the name of your store script, I might be able to help you.

I can’t use it, sorry. citizen:/scripting/lua/scheduler.lua:867: No such export GetCoreObject in resource qb-core

hi, are you using qbcore? if no then this script is made for qbcore. if yes you should find the right exports name and replace name with what your qbcore name is.

I’m using qbcore, I’m sticking straight to the output. Can you help me?

to be honest, i think you’re loading my script before qbcore scripts. make sure it’s loading as the last resource.

I solved it. I’m glad

i tried this script about three weeks ago and was having issues because i dont use lj-inventory. i have qb-inventory, will it work now even though lj is a dependency?

lj-inventory is just a reskin of qb-inventory and installation is the same for both scripts.
I know a lot of people using it with qb-inventory with no problem it should work fine.

ima try again

i followed the directions and im having the same issue as last time. i third eye the guy to open the pet shop and nothing happens and i cant do anything im forced to f8 quit

I use qb-inventory… Works Fine!

it’s probably because of the wrong placement of code inside app.js

Hey bud I am getting a declaration or statement expected when I add the code to app.js I have copied directly from the readme and just can’t seem to find what is causing it do you have any ideas?