ntdll.dll!RtlpWaitOnCriticalSection (0xaa)

Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

RDR2 version? Latest
Up to date? August 1, 2023,
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Steam
Windows version? 11
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any)
Capture d'écran 2023-08-23 170410

System specifications
What did you do to get this issue? The single-player game works well, and it was impossible to launch RedM on my first screen.

On my second screen it works, but if I unplug it the game doesn’t appear on my first screen.

I want to play on my first screen, but I get this error message over and over again.

I’ve tried all the Youtube and Google tutorials, but nothing.

I’m desperate, I never post messages on the forums, but now I’m very sad.
What server did you get this issue on?
Latest CitizenFX_log file
CfxCrashDump_2023_08_23_15_05_46.zip (1.9 MB)

.dmp files/report IDs
[Window Title]

[Main Instruction]
ntdll.dll!RtlpWaitOnCriticalSection (0xaa)

An error at ntdll.dll!RtlpWaitOnCriticalSection (0xaa) caused RedM to stop working. A crash report is being uploaded to the RedM developers.
Stack trace:
ntdll.dll!RtlpWaitOnCriticalSection (0xaa)
ntdll.dll!RtlpEnterCriticalSectionContended (0x203)
ntdll.dll!RtlEnterCriticalSection (0x41)
glue.dll!::operator() (0x360) (GtaNui.cpp:712)

[^] Masquer les détails [Save information] [Fermer]

[Expanded Information]
Crash signature: ntdll.dll+33ABA
Report ID: si-0f29336375ca495fb84ea128d8bf2cbc
You can press Ctrl-C to copy this message and paste it elsewhere.

If an issue with starting:
RDR2 folder screenshot

Capture d'écran 2023-08-23 171415

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder
RedM client folder screenshot
Did you try to disable/uninstall your Anti-virus? No
Did you start Rockstar Games Launcher not as admin? Yes

Also add what you already tried so far.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

Facing same issue , Pls tell what u did to solve it.

I managed to launch the game on my second screen, then set Direct X instead of Vulkan in the settings, and it worked.

I can now play on my first screen.

Can anyone help me still cant run the RedM same issue

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.