[How-to] Use Extended Video Export (EVE) | FiveM

Extended Video Export has been around for a while, although, it never seemed to work with FiveM. I tried tinkering with it a while back but never was successful at getting it to work and it seems like others couldn’t either.

After a year or so I decided to try and get it working again. This time, with some success. I am not exactly sure why it’s working but I assume it may be related to Rockstar Editor changes FiveM made?

This is my first guide so I apologize if it is not clear but I’ll try my best at explaining the process. This tool is very handy for content creators so I thought I would share my recent findings. :upside_down_face:

How to:

Extended Video Export 0.4.4 [BETA] doesn’t export video’s most of the time due to hooking issues so in this guide I will be using Extended Video Export v0.3.0 Beta (not my file drive). This is an old version of EVE and it doesn’t come with many export options, such as PNG sequence etc. Although, this version exports with Reshade and it seems to be more reliable.

  1. Download Extended Video Export v0.3.0 Beta

  2. Locate your FiveM Application Data folder

  1. Create a plugins folder inside the FiveM Application Data folder, if you haven’t got one already.

  2. Extract the ExtendedVideoExport.asi file in to the plugins folder

  3. Extract the EVE folder to FiveM Application Data\cache\subprocess

The FiveM process is done. Although, the EVE folder needs to be present in the root Grand Theft Auto V folder too, otherwise it will crash when exporting in R* Editor. This may be due to it being hardcoded in the plugin itself

  1. Copy the EVE folder you placed in FiveM Application Data\cache\subprocess

  2. Locate your Grand Theft Auto V folder, this is dependant on what game launcher you use, I use Steam, so it will be in my SteamLibrary

  3. Paste the EVE folder in your GTA V directory

  4. Open the EVE folder, locate the dlls folder and delete all the dlls inside but keep the folder empty and present, otherwise, it will crash.

  5. That’s all there is to it. Make changes to the ExtendedVideoExport.ini and preset.ini inside the EVE folder which is placed in the main GTA V directory. NOT the one placed in the FiveM subprocess folder.

Once you export from the R* editor (launched from FiveM dashboard), you should see the ExtendedVideoExport.log has some entries and after the completion of the export the file will be placed in the output path you added in the ExtendedVideoExport.ini file.

2 preview videos:

13 Likes

Thanks for this, now I don’t have to convert all my shit to SP to get beautiful shots.

1 Like

What is the preset you used in the first video?

1 Like

I have modified my preset since so I’m uncertain about what I used at the time, sorry!

1 Like

Could you share your current one?

1 Like

[FORMAT]
format = mp4

[VIDEO]
encoder = libx264
pixel_format = yuv420p
options = preset=veryslow / b=150000000

[AUDIO]
encoder = ac3
sample_format = fltp
sample_rate = 48000
options = b=320000

Thank you for this! Works like a charm, finally can work on clips from FiveM again :slight_smile:

2 Likes

Everything seems to work except the rendering with reshade. I just can’t get the reshade to work… Could this be caused by the version of reshade i use? Could you perhaps share what reshade version are you using when exporting with it?

Try use the 4.9.1 version of reshade

That is actually the version i am using… The reshade works but the exported video doesnt include the reshade effects i use.

Before I say anything, amazing guide man. Probably one of the best written forums I’ve ever seen on the site. But I’m having some problems with it.

I keep getting this error message

Do you think you can help me out with this? Thanks in advanced.

Thanks for the kind words. I haven’t bumped into that error message before, does that come up when you’re opening FiveM or when you’re exporting?

I use Reshade 4.9.1 but a modified version that removes the no depth buffer detection. GitHub - Not-Smelly-Garbage/Reshade-Unlocked: A generic post-processing injector for games and video software.

1 Like

It happens during export. I’ve tried to uninstall and reinstall eve. Add / remove the EVE.asi from the main directory, etc.

I’m thinking it might be a reshade thing but not sure.

Have you added it correctly? I’m not sure what you mean by “main directory”. The .asi file goes in the “plugins” folder in the FiveM Application data, not the GTA V root directory. Also, make sure you’re using v0.3.0 Beta, the one I linked in the thread.

Initially I only had the .asi file in the plugin folder but when the export didn’t work I tried to add it to the main directory to see if it works; it didn’t. I’m using the v0.3.0 beta you provided in the thread.

I think I just goofed something up somewhere while installing. I’ll get back to you if I get it fixed. Thanks for the responses tho.

1 Like

Does this still work? I’ve done all the steps, the log sees me starting FiveM and loads all the encoders, but FiveM still crashes on startup with an ASI error. Does anyone know what I might’ve done wrong ?

Still works fine for me. Are you putting the EVE folder in the correct location? cache > subprocess?

hello thanks for the tutorial.
but I don’t understand how to take care of ENB and Reshade

Hey, i started getting issues with blending mode camera movement after exporting the video. In the preview, it all looks good, but after exporting camera has some lags or something and movement of the camera in the final result is shaky and kinda teleporting back and forth.

UPDATE. Tested exporting the video without EVE, and the shake/lag effect of the camera is a bit less, but still visible, idk if it’s fivem issue tbh, but i don’t remember having these weird issues with exporting!

But not every exported video has that lag of the camera, that’s the funniest part…