FiveM & RedM when the #$%& are you going to admit and resolve the slow cache download issues

Why is it that there are seemingly endless ongoing issues that result in both FiveM & RedM cache downloading at the speed of a dial-up connection? (0.1mbps - 2mbps)

Ever singly thread gets a response along the lines of it’s your internet speed, it’s your antivirus, it’s your firewall, It’s your internet (btw no one has internet that slow anymore), etc.

It quite obviously is not those thing’s and in fact issues with your servers. Are these stupid issues plaguing the platform ever going to be resolved because leaving my computer to download RedM’s 3gb of Cache data for over 3 days is ____ ridiculous.

If you are unable to fix these issues then for the love of god can someone provide me with a direct download link from the web so I can put the files into the game myself and for the god sake add a direct download link for the cache updates on your website.

Having to wait 3 days to download cache only to get one of the many errors that plague the platforms once or during the download over and over again is beyond frustrating.

1 Like

Sorry about the anger but as you can imagine it is extremely frustrating in the end if I can just get a direct download link I won’t complain.

1 Like

It works fine for at least 90% of people, just because you’re a special case doesn’t mean it’s an issue with the platform. On that note however, it was announced on twitter:

RedM currently won’t work for new players as Rockstar removed an API service we require to verify you own a legitimate copy of RDR2 on PC.`

So if you’re a new player, don’t bother at the moment.

Additionally, if you’ve played FiveM before, you should never have to download “the cache” again unless you are silly and delete the cache folder. Sometimes deleting the caches.xml file will help but not the cache/ folder. exists. The cache data is somewhere else but I am unsure where or if it is publically facing.

1 Like

Okay, so to clarify I have played both of the service’s before. After issues with the RedM download I had to reinstall my microsoft reditribution files which then resulted in a citizengame error with FiveM meaning I had to also reinstall FiveM.
Is there any way to get a direct download link for the cache files for RedM and FiveM?

Also if I have previously played RedM but then had to reinstall will I still be unable to play?

Because that’s how a P2P/IPFS network is. Certain files are fetched this way for various reasons.

Not necessarily, and one can not immediately eliminate those as not being suspect if the information is not provided, nor can you just assume ‘no one has that slow anymore’

Again, since the files are hosted and retrieved via a P2P network, the ‘servers’ are certainly not at fault here.

I do absolutely understand your concern, however these claims are simply not true.

Oh boy… users being users again.

That’s odd, I normally download my client updates anywhere between 50-80MB/s. I do have a 1Gb internet connection though.

Okay I understand what you’ve said, but would it not be a very simple solution for cfx to provide a direct download link for the cache file or use a host such as GitHub to provide a link.

This would instantly resolve these issues for people such as myself.

To me it feels like people are simply assuming that 10% of people downloading are simply doing something wrong which isn’t that case.

Currently I’m sitting here and after doing a speed test and getting a 39mb download speed and am able to download other things on my computer at 30mps+

If someone can even copy and upload there own cache file for both RedM and FiveM for me I would be happy. It’s just it is hard to run your PC straight for literally 3 days to download something. And then especially if you then get an error which occasionally happens after 3 days and have to start over again.

Spending a week to install a product is very very frustrating.

Especially when your actively involved with RP and other communities on both the platforms.

Yes it seems to be an issue that is only effecting about 10% of users.

Love useful input in forums

Not saying this will help but, have you tried downloading the client while connected to a vpn by any chance? Not sure where you live but, maybe its a country related thing?

I will try when I’m home, I am in Australia so definitely possible. Thanks

If you’re on the same shit NBN I’m on, It’s odd that your download is that scuffed. I slam it down in a matter of moments… Definitely not a contry wide issue. (NSW Here)

I would definitely look at if for some weird reason, the hardware involved may be limiting the p2p download.
What router do you have and your firewall installed (Just windows defender?)

Yeah NBN with the new Telstra modem and Malwarebytes and Avast (windows defender is off).
I have tried fulling disabling all active shields though and checked my virus chests in case it’s ripping out files during downloads.
None of which is happening.

But it can’t be my modem because I bridged my internet connection to join to both my 5g mobile hotspot and modem and combine download speed and then it will improve to about 2.5mbps to 5mbps.

So then it must be either my computer’s interaction with the website or the website itself. Tbh I’m pretty stumped because I do a lot of modding etc and interact with tons of sites and it has only ever happened with website’s that cap the download be speed.
Not saying that’s the case just from past experience.

Also not hardware, all good spec, new gear and Ethernet connected.

Modem model number, please and thanks.

Im not worried about specs or such, more the configuration.

Hotspot is dedicated and routed into the modem or internal in the modem itself?

Actually, check out the very last post at the bottom of this…

Pretty much, Can confirm, Telstra is horse shit and always will be.

If you have a mate that has a different ISP, Please try and replicate by taking a laptop or rig to his place on his network and replicate.

I back off the vodaphone from Kogan, Can confirm, no bullshit like this.

I will check that I’m not at the house currently but yeah the router itself does have a backup sim that’s a 4g connection but the hotspot isn’t that.

I mean I’m connecting my mobile phones 5g hotspot to my pc via wifi to check and I still get the same slow download over my phone’s internet.

The only way that the download speeds up is if I bridge the Ethernet connection to my modem and wifi connection from my phone so my desktop is connected to both my phone’s 5g connection and my home internet NBN.

It could be a Telstra thing possibly as both my phone and modem are with Telstra.

Honestly since they trialed blocking p2p back around 6 years ago, they did and still do have issues thst crop up around torrents, general p2p.
I recall old wow updates being fucked thanks to Telstra while they backed on p2p downloads.

If you have the ability to try and use another persons isp just to test, it may be worth the while.

But I strongly believe its just our Aussie Comercial Overlords fucking us yet again.

By some miracle I’ve really never had issues with Telstra. Everyone else has so many yet I’m completely fine, maybe it’s an old account flag or something but I’ve only had a proper issue maybe a maximum of 50 times over 6 years.

Your not wrong.

Yeah they can be great but they can also be a nightmare. Haha