[ESX/NON ESX] Ultimate modular NPC AI Backup - BackupPro

Hello CHOKO1528,
In order to tell you how to fix the problem, I first need to know how it occurs.
Does your ESX have any special feature, for example a custom shared object event?

Best regards,
the Codineer Digital Team

1 Like

got it thank you so much :+1:t6:

Hi I’m trying to get the plugin to work but keep getting this in my server
[BackupPro] Verifying…
[BackupPro] Verification failed!
then
FXServer crashed.
not sure what is going on?

Please put your Transaction ID in the config file.

I’ve tried that “tbx-Transaction ID” in there and it still crashes.

Have you entered it with the “tbx-”?

Hey @FloatDev , so i bought the big pack from your tebex - and dropped the BackupPro along with the plugins, into my sever… everything looks good in the consol but when i push “U” to open the menu - it crashes me out.

I got this Error:
image

Any thoughts?

Hey SAVRP,
you can fix it by downloading the BackupProPlugins resource (GitHub - CodineerDigital/BackupProPlugins: Just a simple resource to fix problems) and installing it on your server as usual. This resource must always be started before BackupPro. Now you can move some of your BackupPro plugins with their .json files from the “plugins” folder of your BackupPro installation to the “plugins” folder of your BackupProPlugins installation and the error should be fixed.

Best regards,
the Codineer Digital Team

Hi Float,

Just to clarify - Im moving all my plugin files from the “BackupPro/plugins” file, over to the new resource “BackupProPlugins/plugins” right?

Then in my start config, I put this new resource starting above the “BackupPro”.

**** UPDATE ********

Yea, that worked. Thanks.

Hello,

Are we able to add more then one police job?
Our server uses “Police”, “Sheriff”, and “Highway” as esx whitelisted jobs.

In the config am I able to do more then 1 job for allowing the usage of the script?

Hey SAVRP,
at the moment that is not possible. But we will add it as soon as possible (probably today or tomorrow).

Best regards,
the Codineer Digital Team

Awesome, Thanks!

Hey SAVRP,
I have added the feature. It is now included in the latest update. To use multiple jobs simply write them down in the Job field (";" separated)

Appreciate it!

Just to confirm, it should look like this?:
“ESXJob”:“police”;“sheriff”;“savhp”;“security”,

Capture

1 Like

The quotes only at the beginning and the end. It should look like this:
“ESXJob”:“police;sheriff;savhp;security”,

perfect, thanks!

1 Like

I bought the plugin and edited the server config file (I use ZapHosting) and the server doesn’t start whenever I include BackupPro. If I remove it it works. Any tips on how to know what’s happening?

I tried downloading the FivePD plugin too but even if I receive the email from Tebex with the link to download it, I can’t because a page with some privacy error shows up. I’m using FivePD on my server, so maybe the FivePD BackupPro plugin is necessary.

Hello Lt_Rob,
have you entered your Transaction ID in the config file?

And for the FivePD issue try downloading from our Download Center: https://central.codineerdigital.com/

Best regards,
the Codineer Digital Team

Hey Sorry for not getting back with any feedback, Been a rough week lol.

So i tried using the line of code (with the latest backuppro version) and i get this error, if i try to do more then 1 esx job:

[ script:BackupPro] Failed to instantiate instance of script BackupProServer.BackupProServer: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: �. Path ‘ESXJob’, line 4, position 9.


UPDATE

Not sure why, but it the error came from when id copy and paste the jobs in, instead of manually type them. Strange.

so now with no errors, we still aren’t able to use multiple jobs. the menu doesn’t open if i have more then 1 job entered.

Hey SAVRP,
the problem with the unexpected character is probably some sort of charset issue.
I am going to find a solution for multiple jobs not working as soon as possible.

Kind regards,
the Codineer Digital Team