Client/server game mismatch: rdr3/gta5

Hello,

I just startet my local server.
It is starting up as it should.
But when i try to connect to the server in RedM, it says;
image

Any ideas?

Best Regards.

Did you launch your server with +set gamename rdr3 ?

1 Like

Yes i did :slight_smile:

May seem silly, but did you launch RedM Client or FiveM Client? If RedM Client, do you have your UpdateChannel=Canary in CitizenFX.ini? if so, delete that line altogether.

2 Likes

I launch RedM ofcourse :slight_smile:
I’m not sure i follow what you are saying. I dont have a CitizenFX.ini in server files.

in your client files.

The only thing in that file is;
[Game]
IVPath=D:\Rockstar Games\Red Dead Redemption 2

Please type gamename in your server console and share the output

You need to review in your client file

I’m having this issue and have not been able to resolve it. I did put +set gamename rdr3 on the bat file but its not working. Is there an issue with the latest version of FiveM and txAdmin being integrated?

did you fix it?

bro did you find a fix for this

gta5 bro

(Based on Localhost)

The reason “Client/Server game mismatch: rdr3/gta5” appears is because the server your trying to run has files for rdr3 but it thinks its running gta5 scripts (i think :thinking:). Basically confusing it which is why you need the " +set gamename rdr3 " so it knows what files to run when booting a server.

One way I found that works for me is by creating a ‘run.cmd’ file (which was used in old fivem versions)
Here is the FiveM version:

Therefore, if you want this to work with RedM this is what you should change this to:

The setup is similar to setting up a FiveM server so after adding a ‘run.cmd’ file just start your server with the .bat file :slight_smile:

I have had no problems with running the server this way or how it was explained in part 9(windows) / 12(linux) in d0p3t setup guide: How to setup a RedM Server

Hope this clears up some problems :slight_smile:

Still not working for me. I Have Setup the Server how described
How to setup a RedM Server

And add the old run.cmd and put this in the start.bat
cd /d C:\MyRedMServer\server-data
C:\MyRedMServer\server-files\run.cmd +exec server.cfg +set gamename rdr3

But it says still Client/Server version mismatch

Same for me

same here i tried it under fivem and it launched a fivem server… not sure why, i followed the directions completely in the setup guide. not sure what is going on and when i retrace the steps it tells me i cant run the application on my computer… really lost here…
after redoing the server part once again did as instructed and get this…

image
image

The very last line of your server.cfg

License key for your server (https://keymaster.fivem.net)

sv_licenseKey PUT_YOUR_LICENSE_KEY_HERE

@garrett_slevin The Server is not loading the Server.cfg check the Server-data folder.

it is in there… that is the first thing i checked… if you see the error it says resource monitor doest support current game…