[CFX Keymaster] Will not resolve entire VPS IP range

added to the pull request. It is on the FiveM devs to pull it in now…

2 Likes

Thank you so much your your amazing research and help!

Looks like you’re having a completely different issue than what this thread is about. That error tells me you’ve used the wrong IP when registering your key.

You need to use the public IP of the box you’re running the FiveM server on. On the computer the server is running on open a web browser, that’s not using a VPN addon or proxy, go to the website https://ipchicken.com/ or https://www.whatismyip.com/ to get your public IP. Go to the keymaster server and register a new key with that exact IP address. Make sure you launch the server with that key as soon as possible, in case your IP changes shortly after due to a router/modem reboot or something (Most people’s IP stays the same for months, a few people’s change almost daily).

Hopefully that helps.

Was trying to help a friend set up a dev server to test his car liveries and he was getting the same error about being unable to resolve the IP.

Friend’s IP: 184.155.244.119

Seems to be related to his ISP guessing by this post (same ISP):

That IP uses a Ubersmith based Rwhois server which I specifically solved for on my initial solution. As pictured I was able to even get keymaster to register using that IP address. Your friend must be doing something wrong on their end…

Albeit this provider does not offer much of the standard data variables and crams the important info into one variable all the required data is there to make a successful parse and validate the IP address for keymaster.

Have you heard any info back about xmission IP’s? I still am having the error: Could Not resolve the IP Specified.

You would have to reach out to @deterministic_bubble as to why the pull request has not been accepted yet.

It doesnt look like im able to message @deterministic_bubble but hopefully he will see this post.