Cant launch after first install

RDR2 version? 1.0.1311.27 (Latest)
Up to date? Yes
Legit or Pirate copy? legit
Steam/Epic Games/Social Club? Steam
Windows version? Windows 10
Did you try to delete caches.xml and try again? Yes
Error screenshot (if any) n/a
System specifications Ryzen 5 3600x, 1660ti, 16gigs of ram clocked at 3200mhz
What did you do to get this issue? Launch RedM
What server did you get this issue on? N/A
Latest CitizenFX_log file N/A
.dmp files/report IDs****Before you begin, please read the Client FAQ and Common Questions topic.

If you did not find a solution, fill out the following template and remove this top text.

I have just installed RedM after some of my friends have, I go to launch it, it pops up and says “Starting RedM, We’re getting there” as soon as the bar fills up, it closes and nothing happens, I have tried doing the only fix I have found online (Closing steam, opening the rockstar launcher, and trying it then, but still nothing)
Any help would be appreciated, thanks

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot: