YMAPs not loading properly

I’ve set up the things right and I have 2 ymaps loading in fully but tis map by racingfreddie
The map comes with it’s own ymap which means it should work

In the description it says that you need map builder pro 2.2.

2 Likes

it’s because in the ymap a lot of the objects load through their hash id’s. u need the actual name of the props to make them load.

No offense, but that’s nonsense. Props in a ymap can be loaded via their hashes just fine.

What’s going on here, though, is that the props are simply NOT FOUND. When you drop a ymap into OpenIV, open it again, and it can’t resolve the prop hash(es), it will just use the hash: a clear indication that the prop was not found. 99% sure the OP misconfigured the addon props mod (and/or used the free version, whereas maybe the Patreon version was required?).

1 Like

i stand corrected. OP made it for SP use, could be a big part of the issue? i worked with another ymap of OP and still… all the props that are being called up by hash don’t spawn and the rest does. you think there’s a way to still make them spawn @meimeiriver?

Considering that vanilla SP has considerably more DLC’s loaded (basically, FiveM is just a skeleton setup), there’s a very good chance his missing objects are, indeed, due to using DLC props not loaded in FiveM.

To get his props to spawn, best way would be to identify the missing objects first; aka, drop ymap into OpenIV in SP game, open it again, see what prop names got resolved this time, and then compare to the ymap xml with the one with just the hashes in it.

The hard part is then, once you’ve isolated the missing objects, to create a mini addon props archive for them yourself. Which is to say, copy the objects from SP (preferably renamed, so as to avoid conflicts), along with their corresponding ytyp entries (also renamed). Since this is FiveM – and I’m very new to FiveM myself – you could just drop the extra props into the stream folder, along with the ‘addon’ ytyp and/or manifest file. Whether it will be worth all the hassle is up to you, of course (and usually the original author, when writing for FiveM, supllies the needed extra props himself).

1 Like

P.S. Just checked the original YMAP of the OP. It contains no hashes for me. :slight_smile: (On SP). If you create a _manifest for it, with CW, you can see what it needs:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<CPackFileMetaData>
  <MapDataGroups/>
  <HDTxdBindingArray/>
  <imapDependencies/>
  <imapDependencies_2>
    <Item>
      <imapName>escar1</imapName>
      <manifestFlags/>
      <itypDepArray>
        <Item>def_mapbuilder</Item>
        <Item>v_lev_doors</Item>
        <Item>apa_int_mp_doors</Item>
        <Item>apa_int_mp_h_props</Item>
        <Item>v_kitchen</Item>
        <Item>v_fastfood</Item>
        <Item>v_rooftop</Item>
        <Item>v_office</Item>
        <Item>ba_prop_battle_dj</Item>
        <Item>cutsobjects</Item>
        <Item>v_minigame</Item>
        <Item>v_bar</Item>
        <Item>lev_des</Item>
        <Item>hei_lev_des_mp_dlc</Item>
        <Item>xm_x17dlc_props_accs</Item>
        <Item>v_electrical</Item>
        <Item>ex_int_mp_h_accessories_ex</Item>
        <Item>ex_int_mp_h_seating_ex</Item>
        <Item>hei_mp_residential_heist</Item>
        <Item>v_set_pieces</Item>
        <Item>v_potted</Item>
        <Item>imp_prop_impexp_garage_equipment</Item>
        <Item>v_sports</Item>
        <Item>v_bathroom</Item>
        <Item>xm_x17dlc_props_facility_01</Item>
        <Item>v_bins</Item>
        <Item>p_v_lev_des_skin</Item>
        <Item>apa_mp_apa_yacht_jacuzzi</Item>
        <Item>v_construction</Item>
        <Item>v_fences_2</Item>
        <Item>hei_v_heist1</Item>
        <Item>ex_prop_tv_settop_remote</Item>
        <Item>xm_x17dlc_props_lab</Item>
        <Item>v_trees</Item>
        <Item>v_ng_proppatch_01</Item>
        <Item>v_ext_veg</Item>
        <Item>v_bush</Item>
        <Item>xs_prop_arena_obstacles_scifi</Item>
        <Item>v_seating_tables</Item>
        <Item>v_traffic_lights</Item>
        <Item>ba_prop_battle_lights_02</Item>
      </itypDepArray>
    </Item>
  </imapDependencies_2>
  <itypDependencies_2/>
  <Interiors/>
</CPackFileMetaData>

1 Like

i’ve tried copying the original files and putting them in the streamfolder, but it didn’t work all that well. tbh i think i messed up somewhere but it was a lot of work.

i’m guessing i just need a _manifest for this as well, but whereas you have more experience in SP compared to FiveM, i’m more acquainted with FiveM and have 0 experience with mapbuilder, menyoo or anything like it

the ymap i’m talking about is the indoor kart track made by OP - OG Indoor Go-Kart Track - GTA5-Mods.com.

EDIT: got a hold of Map Builder 2.20, chucked the missing parts into the streaming folder and everything eventually worked. it did make it a pretty big folder to stream though…

1 Like

I am also having issues with maps loading in-game, inside of the Codewalker view they seem completely fine. When imported into FiveM, it seems to warp objects around & things like the front gate won’t load in at all. I have tried removing subfolders inside of the stream folder & a few other things from youtube. But to no avail, does Anyone have any ideas ??




Update
Found that rolling back to the original Police department spawns in the missing gates, something with the custom map must be conflicting with the 2 gates at the MRPD carpark. Still Unsure what it is, as for the fences etc i’m hella confused.

Blockquote