Where does one change the toral allowed startup time?

  1. Where does one change the valuable for the Total startup time? My server has alot of custom clothes, and I changed the startup time for one resource to 600 seconds. But it’s stuck in a bootloop every day after the scheduled restart because the total time is 60s. That should also be higher, but I can’t find where to change it.
> txaEvent "serverShuttingDown" "{"delay":5000,"author":"txAdmin","message":"Server restarting (failed to start in time).

Restarting Server (server failed to start within time limit - 600s max per resource, or 60s total).

It doesn’t make any sense to me how one resource is allowed to start for 600s but the total startup time is only allowed to be 60s. Then it’s gonna be in a bootloop forever. Where do I change the value for the total start up time?

This looks like a txAdmin thing- @tabarra might know?

Let me guess, your txAdmin is outdated, right?
The latest recommended (big blue button) artifact is very outdated and ships with txAdmin v4.17.1, which has a bug impacting server boot time calculations. Updating to artifact 6117 or newer should solve the issue.

If you are already updated, just go to txAdmin Settings > Restarter > Resource Starting Time Limit.


That is correct, Ill update now and see if it fixes it!


Can confirm it was txAdmin. Now it booted without any problems. All I did tho was get it directly from the Github and removed the old monitor folder. Thanks for the help!


1 Like