vMenu Permissions

Hello, So I configured the permissions.cfg file from vMenu, But I still have all the perms, I am not admin or anything, I have tried everything now, But everyone can still access everything in the menu, Please help.
This is my permissions.cfg: https://pastebin.com/7SBXTwzd
and this is my config.cfg: https://pastebin.com/dqwwhBsa (not all of it only the start stuff)

Theres a message in console saying “vMenu is set up to ignore permissions!”

exec resources/vMenu/config/permissions.cfg

Put this before you start vMenu.

1 Like

Still doesn’t work.

Interesting, it should have done. Have you followed this tutorial?

https://docs.vespura.com/vmenu/permissions-ref/

Yes, Idk what’s wrong

The file path to the file is definitely correct?

If you mean the exec resources/vMenu/config/permissions.cfg, Yes

bump, I really need this fixed.

Same problem, Anyone know how to fix?

2 Likes

Fixed, I updated vMenu and it worked.

2 Likes

Have the same problem, most updated version.

same for me. bump

Check if vMenu is inside a folder like " [some_name] "

I think you need to have exec resources/vMenu/config/permissions.cfg before start vMenu. This is what the vMenu install document says: " Go to your server.cfg file, and add exec permissions.cfg at the very top of the file" then it says " Now, add start vMenu somewhere inside your server.cfg file, position doesn’t matter as long as it’s below the exec permissions.cfg line."

Make sure you put in a valid steam web api key near the bottom of your server.cfg.
I had the same issue until i added a steam api key.

Looks something like this in the server.cfg file

# Steam Web API key, if you want to use Steam authentication (https://steamcommunity.com/dev/apikey)
# -> replace "" with the key
set steam_webApiKey "put key here"

ik this is late but cop your permissions and paste it where ur server.cfg is and open server.cfg then there should be a line that says # Only change the IP if you’re using a server with multiple network interfaces on the left side of the # hit enter twice and do exec permissions.cfg

Can you help me with my Vmenu

How did you fix it?