vMenu Permissions not working on server

Howdy,

So I am trying to run my FiveM Server with vMenu, and the permissions.cfg doesn’t seem to execute properly no matter what I do. I have tried reinstalling the permissions.cfg, I have tried reinstalling vMenu and I have tried doing both at the same time. I went to do some work on my localhost where I thought I would try the permissions.cfg on that. The permissions execute perfectly and work the way they are set up. I can’t have anyone or group to have access to everything as it makes MumbleVOIP only work when people are in the same vehicle.

Does anyone know what would be causing this issue?

I am using an esx server and it is on the latest version of essentialmode, the server is being run off of a VPS.

1 Like

have you added +exec permissions.cfg in the server.cfg?

Hello,
You have to add at the start of server.cfg this:

exec permissions.cfg if you have the permissions.cfg in the same folder as server.cfg

exec resources/vMenu/config/permissions.cfg if you have the permissions.cfg in it’s default location…

If you have already done that, please explain your problem better.

Also, read the documentation of Vespura, the owner of vMenu to understand it better and get it work…
Have a nice day!

What are you hosting your server on? We run on zap hosting and when we converted over to Tx Admin verison it stopped working, still yet to find a fix.

Yes I have

I’m running a VPS which is running of OVH Servers

Yes I have done that. So what has happened was I have tried to configure the permissions, I have tried reinstalling vMenu as a script alone, I tried reinstalling the permissions.cfg on it’s own and I have reinstalled both as one. So I have reinstalled it 3 times. I put the exec permissions.cfg below start vMenu. When I launch the server, it say “vMenu setup to ignore permissions” and it never executes the permissions.cfg but when I put it the line above start vMenu, I don’t get the error but everyone gets the base permissions as if vMenu was just installed with no permissions.cfg

I need vMenu voice enabled so that my voice script (MumbleVOIP) works, but if I enable everything for my owner group it only allows people to be able to hear each other when they are sitting in the same vehicle and by enable everything I’m talking about 'vMenu.Everything"

I recommend you put the + exec permissions.cfg at the top

Use it like this.

exec resources/vMenu/config/permissions.cfg
ensure vMenu

then set the “vmenu_use_permissions” on vMenu permissions.cfg to true.

I’m having the same issue but I’m running on EC2 instance(AWS Linux). I joined my server without granting any admin permissions but everyone still has the ban option.

setr vmenu_use_permissions true
setr vmenu_menu_staff_only true

Everyone can still use VMenu despite setting above

Currently I have it it looking like this:

start vMenu
exec C:\RadiantNetwork\server-data\permissions.cfg

And in my permissions.cfg I have this line:

setr vmenu_use_permissions true
setr vmenu_menu_staff_only false

I’m running it off of Windows as it’s just how I’ve learnt to do it on but I have the permissions set to true just not the staff only. Am I meant to have that for admins to use the permissions properly