Vehicle_generator - Can't join server

I have a car pack with a few cars that are added to additional vehicle slots. They are streamed along with the .meta files just fine. In game, they operate normally.

However, I tried to have a few of these vehicles spawn in a spot using the vehicle_generator in map.lua. As soon as I did that, I was unable to join the server and got stuck on initializing.

I did some searching around, but can’t find anything to help me out with this. Anybody have any idea?


Did you try to clear the cache from your client? (don’t remove the game folder in the cache dir)

Yeah, I even tried clearing the server cache. I had some weird error saying it couldn’t download the the map resource. Clearing cache fixed that, but still hangs.

One thing I actually just discovered is the .meta files are not being streamed properly. I’ve got this on the __resource.lua, but its not streaming for some reason.

– the current manifest version level (2016-12-30)
resource_manifest_version ‘77731fab-63ca-442c-a67b-abc70f28dfa5’

– add the files to be sent to the client
files {

– specify data file entries to be added
– these entries are the same as content.xml in a DLC pack
–data_file ‘HANDLING_FILE’ ‘handling.meta’
data_file ‘VEHICLE_METADATA_FILE’ ‘vehicles.meta’
data_file ‘CARCOLS_FILE’ ‘carcols.meta’
data_file ‘VEHICLE_VARIATION_FILE’ ‘carvariations.meta’

I’m not sure if that having a problem would have any effect on the spawning.