Trying to play RedM, owning RDO - can not log into any servers?

It seems to be an issue as I can not log into any RedM servers (I do own RDO, have Steam open and all that). Checking the logs I seem to be stuck at the “triggering initial game load” stage, with the game remaining in the spot shown in the screenshot below.

The RedM server I made for testing shows me as connecting but nothing more.

Does anyone know a fix for this issue?

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

Have you tried launching RDO fully into the game at least once before launching RedM? That often solves issues.

Thank you for your input t3chman - much appreciated! Tried what you suggested (even left RDO running in the back one time) but am still getting stuck at the “triggering initial game load” stage.

I am sure there is just some minor mistake somewhere, but for the life of me I can not figure it out.

can you update me when you fix this? Its also happening to me. It was ok a month ago but then I decided to uninstall redm and then when I installed it yesterday I cant seem to connect to any server.

Of course I’ll let you know if it works.

this helped me

@deerein - Thanks gave that a try but unfortunately this did not solve the issue for me.

Remove conflicting singleplayer mods.

@Disquse - Thank you for your reply! Might be a stupid question but how or where do I do that as I do not have any mods installed/running (using vanilla RDO).

I have the same Problem.
Don’t use Mods as well and was InGame in SP and Online with no luck.

Stuck in the Loading Screen

I have the same problem, can you update me if someone fixes it?

@AuraSixx - It really seems quite a few people with RDO have this same issue, hopefully this can be fixed somehow.
@MrBeanz - Of course, I’ll let you know if we figure this out.


The only way I found to fix it is the following:

I had to make another Profile on my PC with no Administrator Rights.
Then I added RedM to Steam as no Steam Game since it would not Start on the Account with Admin rights. Due to that, it would start just fine for me.

Your Main Profile needs a Password on it though so that it doesn’t log you in right away to the Main Account, and you can choose what account you want to use. Maybe I have overseen something that you don’t need the Password, but that I will test these Days.

Downside is on the New Profile you have to set up (search the programs on main Profile) everything like Programs – Look and such from your Main Profile.

Hope this can help…