Task Item Interaction not sync

Env: Canary, Onesync, 1436, Artifact 4478

Sometimes TaskItemInteraction its not synced between players
I think it’s related to something bigger after this sync issue we got this

function Whisky()
    local modelhash = GetHashKey('p_bottleJD01x')
    while not HasModelLoaded(modelhash) do
    local propEntity = CreateObject(modelhash, GetEntityCoords(PlayerPedId()), false, true, false, false, true)
    TaskItemInteraction_2(PlayerPedId(), -1199896558, propEntity, GetHashKey('p_bottleJD01x_ph_r_hand'), GetHashKey('DRINK_BOTTLE@Bottle_Cylinder_D1-3_H30-5_Neck_A13_B2-5_CHUG_TRANS'), 1, 0, -1.0)


This code works fine for me. Can’t do anything without a proper repro sadly :frowning:

We’re running into the same issue using the exact same code. Currently using Onesync infiinity, server artifact 5402 (latest recommended), Game build 1436.

update: apparently calling this directly after taskiteminteraction and taskItemInteraction_2 fixed the problem for me.

Citizen.InvokeNative(0x2208438012482A1A, PlayerPedId(), true, true)

did you manage to fix this?

The message directly above yours says they managed to fix it and provided a solution.

why would i write here if i hadnt try the above comment tho? :thinking:

I guess you’d be surprised at the number of people that don’t read. How is anyone supposed to know you tried anything if you don’t say that in the first place? In any case, it probably would be a good idea to include more details than just the question you posed below a person who said they solved it.

you are right mb. I found the issue it is related to this below. The people that have this dont see others doing animations. Also it might be because of onesync legacy that i use instead of infinity since on infinity my players cannot see each other or if they can see each other they flicker in and out of existence

Redm doesn’t support OneSync legacy

Legacy isn’t supported, it shouldn’t work at all. Moreover, it’s not anyhow related to the issue you’ve described.

80/80 + queue and with legacy none is flickering. when i turn infinity on people cannot see each other. But yea i guess you are right that its not related :man_shrugging:

Update: The above statement that i made is completely false since i had infinity enabled in my server.cfg and legacy on txadmin mb on that part. Although the Failed to get scenario info by id -1 for task is the issue.