Steam updated and now my controller no longer works

After a recent Steam update on 10/16/2022 my wired Xbox One controller no longer works in Redm. While I was waiting for the server I was playing on to restart I noticed a prompt pop up saying Steam needed a update. Which is how Steam has always notified me about a update. I have never had a issue for the past 3 years. Well after downloading the update I got back onto the server and my controller no longer worked. I have tried everything I can think of and looked everywhere for help. My controller works perfectly fine on Steam and on the actual Red Dead Online version of the game. Yet when I try to play Redm it just does not work. Please I could really use some help figuring this out.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I got it to work somewhat, I just decided to plug in another xbox controller into another usb port at the same time and it made the other one start working. However now each time I tab out of Redm and tab back in the controller does not respond and I need to restart the game.

So after fully reinstalling the game I was able to finally get my controller to work after tabbing in and out. However that stopped working after a few hours and I tried to do a few other fixes that I thought would work but none did. I now realize in order to make my controller work I will need to reinstall redm every single time this happens every few hours. This issue does not happen on any other game I play including fivem so if at all possible could the developers find whatever works on fivem and put it on redm or find whatever is breaking controllers and fix it.