Stealth Mode on weapons doesnt work

I recently added some weapons, with a custom weapons.meta and weaponsanimations.meta file to increase the firerate. This all worked, however you cant enter stealth mode (By pressing LCTRL) anymore. Any reason for this? No script is interfering with this. What line in the metas handles this, or could cause this?

weapon_p226.meta (18.3 KB)
weaponanimations.meta (118.4 KB)

can you help me stream my weaponanimation.meta ??

Sure, whats the problem?

I want to stream the file weaponanimation.meta to modify the way of running and holding the weapon animation , I already have the file but I cannot transmit it :frowning: i can pay for it really

wait so u saying when you shoot and run you dont go into stealth mode?

No, whenever you press control is briefly goes into stealth mode for like half a second, then just returns to the normal stance

oh ayt im tryna get it where when i shoot and run i dont go in stealth mode

so if stealth mode dont wrk on weapons cause of this script plz show me how to add this in

Its not a script thats causing this, its the meta files that i added. This has been solved, btw so the mods can close it