[Standalone] [Paid] Sit Anywhere

so if i pull the object from the admin spawn object it works however the same model in my MLO that ive been building does not work i’m wondering if i sever restart would resolve the issue or could it be a flag issue in my codwalker ymap?

1 Like

The object needs to have the dynamic flag (and not the static flag) for it to be detectable by a script.

1 Like

Well the unclejust’s prison costs 149.00 USD… So you probably will have to add that yourself.

1 Like

how would i check that and can you edit the object in blender to change and or add the correct flags,
or does it need the flag in code walker on the ymap? what about a bone, skel, and pose i’ve noticed that ones that are already on the list that don’t have a bone, skel, and pose don’t seem to work like prop_couch_sm2_07

1 Like

I have figured this out thank you for your earlier reply which helped me think of the flags in the ytyp which solved my issue

i think they have a subscription for $20 for the mlo

1 Like

I’ll take another look at it tomorrow.


So it’s automatically set to false. And it still makes it to where you sit down with e. Even if it doesn’t prompt you that you can sit there. If you flex e, it looks for the next available seat.

1 Like

can you sit in the gabz judge chair in city hall

1 Like

Yes, you can sit in the judge’s chair in the Gabz townhall.

1 Like

Maybe the command it’s binded for some reason.

Try to put this in your f8 and see if stops: unbind keyboard e

Wow, In my opinion is soo good.

1 Like

It’s the script. I took it out just to see if it would still do so. Nothing would happen when you flexed e anywhere. With it installed. No matter if it’s only set to target, you can still flex e to sit down. Or do /sit. It’s conflicting with other activities that require e but have seats nearby.

1 Like

i think this is happening to me to i cant get into any menus that require me to press E or use any script with E as the hotkey.

Exactly the issue. If you have a menu too close to a chair. It’ll sit you down and sometime collide with the menu

[   1614406] [b2802_GTAProce]             MainThrd/ __Lua_InvokeNative: execution failed: Error executing native 0x9f47b058362c84b5 at address FiveM_b2802_GTAProcess.exe+1638624.
[   1614406] [b2802_GTAProce]             MainThrd/ ^1SCRIPT ERROR: Execution of native 9f47b058362c84b5 in script host failed: Error executing native 0x9f47b058362c84b5 at address FiveM_b2802_GTAProcess.exe+1638624.^7
[   1614406] [b2802_GTAProce]             MainThrd/ ^3> GetEntityModel^7 (^5GetEntityModel.lua^7:6)
[   1614406] [b2802_GTAProce]             MainThrd/ ^3> fn^7 (^5@sit/client.lua^7:1155)
[   1621906] [b2802_GTAProce]             MainThrd/ ^3Warning: [entity] GetNetworkObject: no object by ID 138^7
[   1628890] [b2802_GTAProce]                 8740/ ResourceCache::AddEntry: Saved cache:v1:ca52ba97beb81054173c99bfec00088ed4202337 to the index cache.
[   1635468] [b2802_DumpServ]                10196/ Process crash captured. Crash dialog content:
[   1635468] [b2802_DumpServ]                10196/ GTA5_b2802.exe!sub_140E4A440 (0x75)
[   1635484] [b2802_DumpServ]                10196/ An error at GTA5_b2802.exe!sub_140E4A440 (0x75) caused FiveM to stop working. A crash report is being uploaded to the FiveM developers.
[   1635484] [b2802_DumpServ]                10196/ 
[   1635484] [b2802_DumpServ]                10196/ Legacy crash hash: august-avocado-alaska
[   1635484] [b2802_DumpServ]                10196/ Stack trace:
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140E4A440 (0x75)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140E6D194 (0x335)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140EAF7B0 (0x461)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140E649C0 (0x19b)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140E5E0CC (0x6ed)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!sub_140E7EB50 (0x2d9)
[   1635484] [b2802_DumpServ]                10196/   GTA5_b2802.exe!_runMotionTreeSchedulerTasks (0x2f)
[   1635484] [b2802_DumpServ]                10196/ 
[   1641281] [b2802_DumpServ]                10196/ Crash report service returned si-a97f6ae7bb61488682a0049945403bd3

Some people have been getting a crash due to this but I can’t even figure out why. GetEntity issue of some kind. But why would this cause crashes? Line 1155 of client.lua

I’m a little unsure how that would even be possible. If you go into your settings then keymapping and fivem, is Sit - Sit Down (Seat) listed there?

There isn’t any GetEntityModel on line 1155 in client.lua. I presume you may have modified yours and it’s referencing line 1129?

If the above is true I would presume an object it tried to get the model of is invalid or something. Is it in any specific area that they are experiencing this?

Is my file somehow different than yours? I haven’t modified it

So I figured it out. He’s right. If that is set to false, it shouldn’t sit with e. But if you have esx_sit still installed. You still sit down with e when you aren’t supposed to.