[SOLVED] My plugin won't load

FiveReborn crashes on start (before GTA V window) with Fatal Error: Couldn’t load Gears.asi. This is a mod I’m developing.

GTA Version VER_1_0_877_1_STEAM
Everything is fresh and up-to-date.
Legit Steam copy.
Windows 10 x64
Generic “Couldn’t load Gears.asi”
GTA V folder screenshot: Eh, it’s normal and loads normally.
GTA V/update/x64/dlcpacks screenshot: Eh, fully updated + irrelevant car mods
Filepath to FiveReborn folder: D:\Games\FiveReborn
FiveReborn client folder screenshot: I added plugins
CitizenFX.log: http://pastebin.com/LgMUZM6Z
.dmp files: n/a

So I’m the developer and wondering why my script won’t load. I’m not doing too strange things I hope.
Vehicle address and access with getScriptHandleBaseAddress(). NOPing a bunch of instructions when entering a vehicle. Aside from that simple DirectInput and XInput usage. Any idea what could go wrong? My script doesn’t seem to generate a log anywhere (usually does right when the game launches/script attached).

Update: See last post.

Hello Ikt, first of thank you for developing this mod im loving it!
How are you installing it? cause im using it without problems


Which version are you using? I haven’t tried it with the stable version (4.1.3), but that worked the last time.

As for installation, I just put the .asi in FiveReborn/plugins

I’ll reinstate the old original implementation of getting the base address of a handle later, maybe that’s more compatible than relying on ScriptHookV (or the lack thereof).

Also do you use Custom Steering? Afaik it doesn’t work for Fivereborn (and I can’t find the sequence of bytes responsible for it either) but I can probably find something for FiveReborn.

Strange, MTM works fine for me ikt:

Custom Steering doesn’t work for me though, which IMO is a must for using a wheel in 5R.

I found the issue, thanks for the help!

I’ll try and see if I can get a lite version of CustomSteering integrated. For now, it works normally in FiveReborn. Test build here, configuration for wheels is a bit tricky, usage with controller is as usual.