Social Club Sign in?

Hi. I had this issue couple days ago where I tried to start RedM and I was prompted with Rockstar’s Social Club window asking me to log in to a SC account that owns RDR2. Now I own RDR2 on steam and I can still play that game just fine (assuming my SC club works fine?) but everytime I start RedM it opens that SC window with a message saying “We couldn’t sign you in automatically, please login manually using d…o@a…”.

I don’t have any email nor used any email that starts with the letter d and ends with o what so ever let alone that .xyz domain.
I try to log in with my legit SC account and I’m prompted with the message saying: "This Steam account is already linked to a different Social Club account. Please log in with that Social Club account instead.
PS: I can log in to my Social Club account just fine on the browser.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.