+set onesync legacy doesn't work

So, I decided to fully update my older server. Started from scratch, artifacts 2766, everything new and shiny.

“onesync_enabled is deprecated, use onesync legacy instead”

Ok, no problem. …actually it is. When I added into command line, it doesn’t do a thing. No FiveM* - one sync alpha or anything. No errors, no messages, nothing.

So what am I doing wrong? I tried older artifacts, same issue.

maybe you don’t put key patreon

I’m testing scripts on 32 slot server, you don’t need Patreon for OneSync to do that

1 Like

If you leave onesync_enabled true in your server.cfg you will keep getting this message. Comment that line out and it should remove the error.

I am using +set onesync legacy in my command line and it is working fine.

1 Like

Well, that’s funny. Because it works exactly the opposite way for me.

set onesync_enabled true actually changes my FiveM logo to FiveM* (while, yes, throws me error in server console)

When adding +set onesync_legacy into server command line

cd /d D:\FXserverExM\cfx-server-data-master
D:\FXserverExM\FXServer.exe +exec server.cfg +set onesync_enabled true

Logo is normal again.

Apologies I’m an idiot, no need for the underscore between onesync and legacy. So it should be +set onesync legacy.

Thank you, this is working for me!

I just don’t understand why 5 people are giving me 5 different answers to this.

And then, there’s this… Confusing thing.

Yes, this commit is to make enabling onesync easier in the future instead of the current way to enable infinity and beyond which is

onesync_enabled true
onesync_enableInfinity true
onesync_enableBeyond true

the new commit allows you to enable both with just

onesync on
onesync_population true
2 Likes

This doesn’t work for me?
Udklip

I needs to be in your launch parameters so inside your start.bat should be

PATH\TO\FXServer.exe +exec server.cfg +set onesync legacy

so you dont need it in your server.cfg at all? just in the start.bat?

Just in the start.bat.

Doesn’t work for some reason.

anybody else have the issue when setting to the latest artifact, the ram usage just kept climbing?

@ECHO OFF
:choice
set /P c=Would you like to delete your server cache?[Y/N]?
if /I “%c%” EQU “Y” goto :somewhere
if /I “%c%” EQU “N” goto :somewhere_else
goto :choice
:somewhere
echo “Deleting server cache”
rd /s /q “C:\Users\Administrator\Desktop\PremiumServer\server-data\cache”
echo -
echo FXServer
echo -
start C:\Users\Administrator\Desktop\PremiumServer\run.cmd +exec server.cfg +set onesync legacy
exit
:somewhere_else
echo
@echo off
echo -
echo Server starter by Levy.
echo -
start C:\Users\Administrator\Desktop\PremiumServer\run.cmd +exec server.cfg +set onesync legacy
exit

Put that in your server starter .bat. Change the paths and youll be fine.

this was solved by going to a later artifact

guys i put +set onesync legacy in my comment line and when i run starter.bat it doesnt say warning onesync legacy its fine but when i am connecting to server with 50 slots it says onesync (policy type onesync) is not allowed for this server or a transient issue occurred

Have you found a fix yet ?