Server resources are downloading slowly

Hello, on my server, the internet speed is very slow while the resources are loading on the players are connecting to the game screen. When the same players connect to other servers, resources are downloaded very quickly. Only on my server, downloaded files are downloaded very slowly when selecting both resources and cars. There was no problem until 1 month ago. Please tell me what I should do.
Note: artifacts is the latest recommended (version 7290), caches were deleted and tried

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

Get some monitoring software and see if it’s the server; slow download can be caused by either side and it’s usually indicative of a network hiccup somewhere. If for nothing else, you can try setting up a caching proxy - that should help the download speeds.

VDS was loading late depending on internet speed. I’m trying to increase VDS internet speed, I’ll get back to you once I try it.

What’s “VDS”?

I guess a Virtual Dedicated Server