Server Crashing (FXServer.exe stopped working)

Recently we have been having an issue where our FXServer.exe will just stop working. It seems to be pretty random and recently and does not always generate a DMP file. lookin at the crashes now I think we have a DMP file for one of the crashes though. If anyone could look at it and please let me know what you think. We have been running this server for almost 2 years now and have never experienced something like this. Currently we are running 2 servers that share database. Both are essential mode esx base. Due to this we have updated our artifacts multiple times. Cache is deleted automatically every restart. Please let me know if you need any more information, I will be happy to provide it!

Up to date?
“version” is “FXServer-master SERVER v1.0.0.1259 win32”
default: “FXServer-master SERVER v1.0.0.1259 win32”

Windows version? Server 2016
System specifications Very high system specs, i7 and SSD, please let me know if you need more details on this
What did you do to get this issue? Nothing
.dmp files Below

7122e8ed-e4c5-4882-943f-099a84d12b18.dmp (1.1 MB)

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the FiveM community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!

1 Like

Server just crashed again, this time without any box saying it stopped working. The server just closed.
This is the dump file from the crash.

268655c2-ab1b-48fe-9c65-f84d17c1f21c.dmp (1.1 MB)

What artifact are you running?

1 Like

I am not sure which artifacts the first dmp file was under but the second dmp file was while running the following version. This is the most recent artifact from 5/21/2019


It just happened again, the server closed with no error box. I am almost certain a hacker that I was about to ban was the cause. Can you please look into this and see if you know what is going on.

17be4bee-4368-4940-9d6b-4a33f6e42cfa.dmp (1.1 MB)

I’m getting the same issue only no crash dumps. This happens randomly.
I first attributed this to possible server load with additional scenery, but after removing said resources I still get the same thing. Windows Server 2016 just says FXServer.exe stopped unexpectedly.
I’ve checked my crash folder and nothing is in there. Please let us know what your fix is for this issue. We’ve also been seeing a lot of brute force RCON attacks as of the last 2 days. Any word on how to prevent these people from getting our info from the API?

Really would like to fix this random stop issue. Many thanks.

Just as an FYI, I am running all of the latest versions, and this started happening about a week ago. Prior to this, no issues.

1 Like

Anybody hear anything regarding this issue?

After a few days of constantly upgrading our artifacts the issue was gone. I would suggest starting there.

Which artifacts, and what are artifacts? You talking about the resources?
The server was running fine up until 3 days ago. Nothing has changed.

Have you ever even updated your server as you have no ideas what artifacts are

As I had mentioned, I am fairly new to this. Has the server been updated, yes, right now it currently is running version 5.2.0. Per the start up, it’s up to date. The problem is that since I’m new and not familiar with the term “Artifacts” much like the other forums, no one bothers to explain what they are talking about. I appreciate you reaching out, but some further explanation as to what Artifacts are instead of insulting me because I’m new to this would be appreciated.

After a bit of research, I now know that the “Artifacts” you mentioned are the files that FXServer.exe uses, along with the citizen folder. I’ve just updated them with the 1323 version released today. I’m sorry if I seemed like a jerk regarding my previous reply.
Will keep everyone posted and let you know if the artifacts from 1323 resolve this issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.