ScriptHookVDotNet

Is it possible to use ScriptHookVDotNet with this MP mod? I would like to to be able to use the Map Editor mod and make gamemodes for a server I run like the GTA:O Creator except I load the maps and such

place the ScriptHookDotNet.asi in your \plugins folder.

1 Like

What about the dll and the scripts folder?

\plugins\scripts

After doing that when I start my game it gives me the error about Citizen Script Loader and that I need to take the script loader out of my plugins.

@Solmex same, been trying to mess with it since I saw this posting… not working :\

I’ve gotten as far as the native trainer showing after pressing f7. If I try to enter the map editor however, the game crashes.

Try putting ScriptHookDotNet in your GTA V folder.

Afaik all the ASI files should be in the /plugins folder, and none in the GTA V folder. The point of having a different folder is so you can play GTA Online without issues, and with the ScriptHookDotNet in your GTA V folder you will probably get banned from GTA Online (believe me, i know. Took R* 5 minutes to ban me with only Scripthook in my GTA V folder)

However, the .ini /cfg files of your clientside mods should be BOTH in your FiveReborn and in your GTA V root. Did you check that?

I do have the ScriptHookDotNet and .ini in both folders. Has anyone else confirmed the mod works in FiveReborn? It’s not a deal breaker for me. Just thought it would be interesting.

Edit
BTW, I do have the mod working fine in single player. It is just in FiveReborn I cannot figure it out.

Put all the asi files in your /plugins/ folder.

ScriptHookDotNet go’s in your GTA V folder.

I’m not sure the mod will work in its current state. I have it setup exactly as you say and I cannot get into the actual editor. I can “load” a map, but none of the props appear.

I’ve also tried to install the ScriptHookV and the ScriptHookVDotNet libraries inside my \plugins\scripts folder (for the .DLL files) and the \plugins folder (for the .ASI files) and at last my FiveReborn folder (for the .INI files) but apparently at one certain point of the loading screen when joining into a server, the game would suddenly disappear without any crash window appearing on the screen.
I’m not sure if I’m doing something wrong or the mod just doesn’t support such scripts yet but I really hope you guys can make these scripts to work because there are so many good looking mods/scripts that would make the game more enjoyable and realistic.

@Boss you said there’s no support for .net scripts, but in this thread you clearly instruct how to install/place the ScripthookDotNet, since the new update it’s no longer working. Please help us to unterstand why the devs had made this decision? I personally respect all devs and moderators of porject /\ and love the work they have done, but since the last 3 updates we are getting from time to time more limited with our Roleplay and want to understand why this happens. There’s been no changelog of the newest update by far. With best greetings Benni @kanersps

1 Like

Blame Kaner for it. He said that “it reduces people who have weird errors” which IMO is a bullshit excuse.

As for getting SHDN working: just rename it to something else, mine’s SHDN.asi

Having the CLR loaded causes crash reports from all other game crashes to be ‘corrupted’ to show only a crash in the CLR code due to a bug in the Microsoft exception filter in the CLR.

Because the pΛ developers have no influence over the Windows source code, they can not fix this issue except by disabling loading the CLR (or alternately, signing up for WinQual error reporting, which has a program fee of $1000/year and requires to be an incorporated entity).

What was the last version of FiveReborn or MultiFive that SHDN and ScripthookV worked?

ScriptHookV still works?

What about now? it doesn’t work even if you rename it?

edit: fine natrium, you didn’t have to lock the thread.

ScriptHookVDotNet is no longer supported (blocked) by FiveM. Any scripts that require it will not work.