[Repro] Mumble Chan_fromID : Channel id X not found. error

Server

Operating system: Linux
Artifact version: Latest 2409
Resources: ~= 120
Infinity : Activated
Player needed : Yourself is enough :upside_down_face:

Incident

I’m using a script to split people into mumble channels, here is the code full code :

It does set you in a channel based on your coords, to also make people around you, hear and talk to you, we use : MUMBLE_ADD_VOICE_TARGET_CHANNEL and it works perfectly, the issue is that your server console get spam whenever you switch and talk at the same time.

Interesting fact : on the server side i created 5 permanent channel 1 o 5 and as you can see it spam channel 6 or 7 which is the number of channel + 1.

Here is a full video showing everything and a better explanation :

1 Like

Up ^^
Really need a way to disable those warning if possible ^^

EDIT : Tested today, still a thing on artifact 2432

Using 16k channels so no, this ain’t an option.

UP, this is still a thing :sweat_smile:

Does the voice also stutter for an instant?

Why are you expecting something to get fixed if you’re not posting any repro steps?

You do have a full repro.
The main topic got a link to an actual full video showing everything and you also have the source code.

Steps are pretty easy :

  • make a resource using the linked script
  • connect on the server (doesn’t require more than yourself)
  • move around (using a noclip system would be easier) keep pressing your talk input button and switch from zone to zone (zone = 256m square)

Everytime you will switch from one zone to another one while having the input pressed server should be spammed with the “errror”.

You’ll recognize the script, you gave me the idea and a big part of it back in the day.

As always, Thanks for your help :raised_hands:

Ah, steps weren’t clear from initial post.

Indeed, my bad I added the repro inside of the video instead of making a simple text list in the post, will keep that in mind for the next report.

If you need more infos, testing or i don’t know, just ask