[Release] Manual Transmission & Steering Wheel Support (Client)

Manual Transmission & Steering Wheel Support

This mod allows you to use your steering wheel in FiveM, as well as enabling manual transmission. It’s very much recommended to use a controller or steering with this mod.

There are no plans to make this server-side. Stop asking me.


On GTA5-Mods.com



FiveM installation

  1. Create a plugins folder in :snail: FiveM Application Data
  2. Put Gears.asi and the ManualTransmission folder in there.


Check the README, or mess around in the menu. The mod obviously only work in servers allowing client scripts!


Source code

On Github

Bug reports

I don’t check here often. Places where I can be reached. Always @ mention me!

Please include the Gears.log file. If a steering wheel set-up is involved, also mention that (and what you did to set it up).


Looks fucking awesome dude! Nice one!

1 Like

Where is the application data folder? EDIT: I saw something about G920s, what is the issue with them as that is what I use

1 Like

My friend has a g29 and his woundn’t work for anything. But i have a tmx wheel and it works just fine. If you need help dm me and ill help the best i can.

A menu thingy!

In Story Mode, if you run ScriptHookV, ScriptHookVDotNet and this mod, things crash.

Remove ScriptHookVDotNet and things are fine tho. No idea why. Menyoo supposedly also gives this problem.

G29 should work fine since 4.1+ as long as everything is configured properly…

1 Like

Yea my friend was having weird errors but its whatever. How do you get that menu? Like what key


Something something freshly copy-pasted from another project.

I havent tried story mode yet, I got the mod to work in FiveM except nothing is configured correct despite me going into Dutil or whatever and setting it up. The car just revs and if I put it into drive it does burnouts with the wheel locked to the left at like 25 degrees

1 Like

its a small bug, turn off the mod in game then turn it back on. Then it will be fixed.

So for me hit Y to disable mod? Cause like its as if nothing is bound yet it is. Thanks for quick response

1 Like

What ever the key is set to (mine is set to \ but it depends if you changed it. Also do not change the shift mode, just the mod itself)

Only problem is nothing is bound, net even that

Cause its bound to a button on wheel, how do I make it on keyboard?

It worked! Only thing is H-shifter doesn’t work and its in Real Auto (Like a real car, I have to go in N and R but otherwise Auto) But other than that it works perfectly! The hand in 1st person isn’t exact but 10/10 nonetheless

The readme contains a useful index that links to the controls section.

There’s also 3 gearboxes, when using a controller only the sequential and auto are available. For the rest, H-pattern shifter is also enabled.

Okay mod stopped working. The game itself wont load. Just made clean install. when i take your mod out it works.

Post logs or something. “Stopped working” isn’t a very descriptive description :confused:

Meanwhile, porting over 900-ish lines from a cmd prompt to a menu system! :smiley: :gun:

Okay nvm for what ever reason it doesnt work with the new fivem folder or something im not sure.


Works fine here.

I added the manual transmission folder and gears.asi in my plugins and it keeps giving me an error about something in my plugins folder. The mod works just fine in single player but not in FiveM. Anyone have any thoughts on how to fix this?

EDIT 1: Doesn’t crash my game but doesn’t load the mod either.