[Release][FXServer][ES5] CarWash

Has anyone figured out how to make the car wash actually work? I’ve loaded the IPL spinners, but like make water shoot out? It looks like

brain::register_world_point_script_brain(“launcher_CarWash”, 100f, 1);

does the actual cut scene of pulling the car through, washing it, etc… But since no one has actually done it, I assume its not easy? I guess I could go grab all the native calls and replicate it. Or figure out how to launch that script? If anyone knows and can break it down before I go figure out that would be great. :stuck_out_tongue:

2 Likes

I can try to do it but that means i have to remove the North carwash, and i can’t promisse you it will work

Hi, I have a little problem, here is a screen:

Then once to the place to wash my vehicle, I press on enter, the money is debited but the text down is recovered desuite, the other texts are not displayed knowing that the money is taken. I can spam the enter key.

The worry does not come from the script itself. But I think it comes into conflict with something but the question is what? an idea ?

it doesnt actually run the car wash. it takes the money and cleans the car (dirt mud etc…)

i think his problem is with the messages, for some reason Wait() and Citizen.Wait() are not working anymore i tried both to make the script wait 5000 milliseconds and it just doesn’t wait, so what this means is that the messages are in fact displayed, but if the player is still inside the green circle they are almost instantly replaced with the press Enter message to clean the car and it wasn’t doing this before so idk … (haven’t tested with this one, only a version for vRP that i am making)

@TheSpartaPT Knowing that it does not wash the car, I have blood on it and it does not wash it at all. I tried with blood because the ground did not dirty the car.

Hi all,

To wash a vehicle you can use WashDecalsFromVehicle(vehicle, 1.0) to remove mud, blood, …

The second parameter seems to be a float. I tried 1.0 and 100.0 => Same effect.

Hope it’ll help :slight_smile:

Hey,

you can link your files please ?

good tweaks to it, can it add maybe 2 more location? or how I can do it like what will need it to be done. Thanks

any progress made on this yet ? (sorry dont mean to rush you - just curious )

on fx vrpp server not work

Anyone else having the issue when you press enter nothing happens?

everything depends on the version of FiveM and the version of EssentialMode you’re using, that being said, i’m currently in the process of updating this to the latest versions of both, sorry for the delay i’ve just been too busy with my life.

i’ve already done most of the work, and i’m currently having a problem that i’ve been trying to fix for 5 hours now, for some reason i’m not being able to trigger my client events on my server side script, even though the client side script is able to trigger the server side events, i’ve been looking into the syntax of everything, and it seems to be fine, if anyone has an idea of what’s wrong with it send me a DM (i’m triggering the events the same way the current downloadable version is triggering them)

Yeah same issue, getting this error in the console:

cfx> Error parsing script carwash_server.lua in resource carwash: carwash_server
.lua:13: function arguments expected near ‘>=’
Failed to load script carwash_server.lua.

Everything else seems to be working other than that, icons are on map, marker and enter message are working, just won’t take the money and clean the car. Any way to fix this?

@combatmedic02 the problem isn’t that, i already fixed that one, the problem now is something with the TriggerClientEvent(), it doesn’t output anything to the console, i’m going to update the script now and you try the new one, it takes your money and doesn’t clean the car or send a message.

@combatmedic02 i’ve updated the repository, just download the newest files, keep in mind i changed the name of the folder and all the files

Will do, I’ll give it a try now. Many thanks for such a quick response. It’s a small thing but it makes the world feel more complete. :slight_smile:

ok idk about you but i was testing right now, and it magically started working, can you give me an update and tell me if it is working ?
and if it doesn’t work i know what fixed it, i deleted everything inside my client cache folder and downloaded the files again

The error I posted before is gone but it still doesn’t do anything when you press enter. I’ll clear my cache and see if this fixes it. :slight_smile:

It seems to be working now. It takes the money and seems to clean the car. The insufficient funds/success messages don’t seem to be working but that’s a minor issue. :stuck_out_tongue: