RedM User Interface Error But Music Plays

RDR2 version?
Red Dead Online
Build ID: 8593540
Installed content updated: Jul 17, 2022 at 11:02 AM

Up to date?
Yes

Legit or Pirate copy?
Legit

Steam/Epic Games/Social Club?
Steam

Windows version?
Windows 10 Home 21H1

Did you try to delete caches.xml and try again?
Yes

Error screenshot (if any)

System specifications
Intel(R) Core™ i7-8550U CPU @ 1.80GHz 2.00 GHz
16GB RAM
Nvidia GeForce GTX 1050 8GM

What did you do to get this issue?
Changed display settings & RedM settings to force computer to use discrete graphics card instead of dedicated card. Now RedM throws this error when starting but will play the red dead music

What server did you get this issue on?
Dakota Riverbend, but I can’t get RedM to do anything besides show this error now

Latest CitizenFX_log file
CitizenFX_log_2022-07-30T181604.log (106.8 KB)

.dmp files/report IDs
f5941726-f9cd-4c63-b85d-6777f1b608c0.dmp (9.7 MB)

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder
C:\Users-----\AppData\Local\RedM\RedM.app

RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus?
Yes

Did you start Rockstar Games Launcher not as admin?
Yes

Also add what you already tried so far.

Literally any suggestions would be appreciated. I can’t figure out what’s wrong with this thing.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I’m now getting ERR_GFX_INIT. I’ve tried all the solutions I’ve found on the forums and reddit such as deleting SGA files. I can start RDO itself just fine but I can’t get RedM to work even after reinstalling it, and my graphics drivers. Should I just try reinstalling RDO?

Did you ever find a solution? I am now running into the exact same problem.

Okay, I sorted it out. For whatever reason, DX12 conflicts with the Nvidia driver for this GPU, forcing it to load (or try to load) RedM with the integrated GPU and not the dedicated GPU. Even using the Windows Graphic settings and/or Nvidia control panel to force it otherwise is ineffective. You’ll have to run the game on Vulcan. If you disable your integrated GPU (via Device Manager) you should be able to atleast nurse your way into the game to change your settings to Vulcan, and then reload with both GPUs enabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.