RedM Rage error: ERR_GFX_STATE

RDR2 version? 1.0.1436.31
Up to date? Yes
Legit or Pirate copy? Legit
Steam/Epic Games/Social Club? Rockstar/social club
Windows version? 10 64bit
Did you try to delete caches.xml and try again? Deleted most of my caches, not able to find this one, but im not able to get in game to make any caches either so… ¯_(ツ)_/¯
Error screenshot (if any) None, goes to blackscreen and i have to manually reboot PC to unfreeze
System specifications i7-8700k 32gb ram, 3080 ti (aka prob not hardware)
What did you do to get this issue? Tried to join a server
What server did you get this issue on? Syn County (trying not to join a billion discords to check other servers, plus this is where all my friends are at)
Latest CitizenFX_log file
CitizenFX_log_2022-07-25T093056.log-Edit.txt (172.6 KB)

.dmp files/report IDs
2090ee2c-4fdc-478f-ba66-35301d3d3bc7.dmp.gamelog (copy).txt (6.5 KB)

If an issue with starting:
RDR2 folder screenshot

RDR2/x64/dlcpacks screenshot

Filepath to RedM folder “This PC>(E:)>Rockstar Games>”
RedM client folder screenshot

Did you try to disable/uninstall your Anti-virus? No
Did you start Rockstar Games Launcher not as admin? Yes, default to regular start, does not boot at PC startup, have to open manually

Also add what you already tried so far.
Well so far ive tried reinstalling both RedM and RDR2, ive cleared my caches, (the ones i know about atleast). Ive moved the RedM install to the same drive, (in fact basically the same folder) as RDR2 main. Tried changing the system.xml file to force to DX12, but didnt seem to do anything. All the fixes ive seen for “ERR_GFX_STATE” say to change your graphics API, but i cant even get into the game to do so. Ive tried Stable release, Beta and Unstable release (canary? not named that anymore in settings atleast) to no avail. My friends have really gotten into this and id like to be able to play with them, so any insight would be amazing at this point.

Hello, this is a friendly reminder because this is your first time creating a topic (or it has been a while since your last topic) in this category.

Please note that most of the support is provided by the Cfx.re community on a voluntary basis. We ask you to be patient; there is no guarantee we have a solution to your problem(s). To avoid unnecessary/duplicate topics, please browse the forums before creating a topic.

To improve your chances of your issue(s) being solved, please provide as much information as possible about the issue(s) you are having. Also —whenever possible— please use the template given to you when creating a topic.

Thanks for keeping these forums tidy!
:mascot:

I also have a 3080ti and have been having the same exact issue when trying to join the Syn County server, it even crashes before I get to try to join a server.

1 Like

3080ti here too, same problem. Tried to change from Vulkan to DX12 but the Game itself wont start anymore. Deleted sga files, still not working.

I only have the RDR Online version, no SP game.

Hey, I also have a 3080ti. The issue here is that the graphics card is overclocked and RedM doesn’t seem to like that. I found a fix and unfortunately it comes having to downgrade the drivers on the card, the plus, it doesn’t really make gaming any different on other games.

I’ll include the link to the build I found that worked for RedM for me and I hope this helps anyone else.

UPDATE: I’d also like to mention, do not update your driver once downgrading. This will just put you back on the drive that was not working to begin with.

1 Like

Ok so ive resolved my problem, i had to go into my system.xml file in your docs folder (C:\Users(yournamehere)\Documents\Rockstar Games\Red Dead Redemption 2\Settings) and under the advanced graphics section you need to change,
this line: kSettingAPI_Vulcan
to this: kSettingAPI_DX12

And thats all i had to do to get it running, after that i just configured the rest in game as you normally would

Mine was already set to that and it does not fix the issue for me. I am going to try downgrading the driver version and see if that works

This worked for me!
Thanks

1 Like

Awesome, glad to hear it works. Spread the knowledge and help others, cause I know I was trying for months to get this to work after I finally had gotten my 3080ti. No reason we should be penalized for spending thousands on a video card :rofl:

1 Like

Yes, I have heard that this works for a lot of people. I dunno the difference of why it works for some and why it doesn’t for others. I would say this “fix” of changing from Vulcan to DX12 should be the first attempt, than downgrade to the driver version I linked.

Cheers

This is the only answer, worked for my 3080 Ti OC and another person’s 3090.

Should add, to disable automatic downloads of new drivers.